Sessionvariablen verschwunden wenn ein <img> nicht auffindba

Alles, was PHP betrifft, kann hier besprochen werden.

Re: Sessionvariablen verschwunden wenn ein <img> nicht auffi

Postby nathandw » 04. November 2010 15:12

@Altrea:
Die 'access.log' listet nur die Aufrufe der zwei Skripte.
Die 'error.log' zeigt nur die Fehlermeldung des zweiten Skriptes (Bild nich gefunden, oder so).
Also leider auch keinen neuen Erkenntnisse. :(

Gruß Thomas
~~~~~~~~~~~
nathandw
 
Posts: 10
Joined: 16. November 2006 18:51

Re: Sessionvariablen verschwunden wenn ein <img> nicht auffi

Postby Knight1 » 04. November 2010 15:14

nathandw wrote:...
files
C:\xampp\tmp
1
PHPSESSID

Sagt dir das etwas? Ich hoffe mal.
...

Ich hatte den verdacht dass eventuell eine dieser Konfigurationseinstellungen fehlerhaft ist. Sie sind aber in Ordnung.

nathandw wrote:...Naja, sagt dass die Sessionvariable nich da ist. Das ist doch eben das Problem, aber warum ist sie nich da, das wüsste ich gern. ...


Das sagt NICHT dass die Session-Variable undefiniert ist, sonst hätte er nämlich auf $_SESSION gemeckert. Sondern dass der Array-Index var undefiniert ist.

Die Session-Funktionalität scheint also korrekt zu funktionieren.

Ich bin mit meinem Latein am ende.

Kai aka Knight1
Image
User avatar
Knight1
 
Posts: 310
Joined: 18. October 2003 10:03
Location: Trier
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate x64

Re: Sessionvariablen verschwunden wenn ein <img> nicht auffi

Postby Nobbie » 04. November 2010 20:55

Nun liegt die Lösung schon so nahe, aber keiner will sie wissen: nun zeig uns doch bitte die Datei /projekte/kitaexperte_core_0.9.1/anmeldung/fehler404.php

Du kannst einen Besen fressen, wenn dort so etwas wie "session_destroy()" oder "unset($_SESSION)" o.ä. drin steht (worauf ich fast wetten würde)...
Nobbie
 
Posts: 7015
Joined: 09. March 2008 13:04

Re: Sessionvariablen verschwunden wenn ein <img> nicht auffi

Postby nathandw » 04. November 2010 21:48

@Knight1: Ja, und ich war schon "mit meinem Latein am Ende" als ich hier gepostet habe. Es ist einfach nicht nachvollziehbar für mich. Ich danke dir jedenfalls für deine Bemühungen.

@Nobbie: "Nun liegt die Lösung schon so nahe" ...ja aber bei mir ist Nebel :shock:
Du hast den Nagel auf den Kopf getroffen, in der 'fehler404.php' hab ich ein '$_SESSION = array();' drin.
Wenn ich das rausnehme, ist das Problem weg!
(Deshalb hatte es wohl auch auf meinem Webserver im Web und auf einem anderen Rechner mit einer anderen Xampp-Version geklappt, weil ich dort die .htaccess nich drin hatte)

Also ich weiß nicht wie ich dir danken soll, so lange hat mich bisher noch nie ein Problem geärgert (geht schon fast ne Woche... :evil: ). Also wenn wir uns mal treffen halt ich dich nen Abend frei :wink: , versprochen.

Also, es klappt jetzt. Aber verstehen tu ich es trotzdem nich :oops: .
Wird nich die 'fehler404.php' nur aufgerufen wenn eine Seite nicht gefunden wird?
Wird die etwa auch aufgerufen wenn eine Bilddatei nicht gefunden wird?

Gruß Thomas
~~~~~~~~~~~~~~~
nathandw
 
Posts: 10
Joined: 16. November 2006 18:51

Re: Sessionvariablen verschwunden wenn ein <img> nicht auffi

Postby Nobbie » 04. November 2010 22:27

nathandw wrote:Du hast den Nagel auf den Kopf getroffen, in der 'fehler404.php' hab ich ein '$_SESSION = array();' drin.


Na also, tausend Punkte für Nobbie!

nathandw wrote:Wird die etwa auch aufgerufen wenn eine Bilddatei nicht gefunden wird?


Selbstverständlich. Der Dateiname und Inhalt spielt keine Rolle - wenn ein Http-Request nicht gefunden wird, gibt es einen 404-Fehler. Und in diesem Fall bedeutet das, dass (wie durch .htaccess veranlasst) dieses spezielle PHP Script aufgerufen wird. Und das zerstört konkret das Session Array.

Was sich der Programmierer dieses Scripts dabei gedacht hat, entzieht sich endgültig meinem Wissen. Ich finde es einigermaßen schräg - und der hier auftretende Seiteneffekt bestätigt dieses.
Nobbie
 
Posts: 7015
Joined: 09. March 2008 13:04

Re: Sessionvariablen verschwunden wenn ein <img> nicht auffi

Postby nathandw » 04. November 2010 22:43

Na also, tausend Punkte für Nobbie!
Genau, die hast du dir redlich verdient!
Was sich der Programmierer dieses Scripts dabei gedacht hat, entzieht sich endgültig meinem Wissen.
:oops: ... das war ich selbst. Asche auf mein Haupt.

Naja, jedenfalls werd ich diese Erkenntnis wenigstens nie wieder vergessen. Ich dachte, die Fehlerseite wird nur aufgerufen wenn eine "Seite" nicht gefunden wird.

Also mein Dank nochmals an @Nobbie, @Knight und an das ganze Forum sowieso. Ihr habt mir sehr geholfen!
nathandw
 
Posts: 10
Joined: 16. November 2006 18:51

Previous

Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest