Debugger

Alles, was PHP betrifft, kann hier besprochen werden.

Debugger

Postby D@ve » 12. June 2010 00:19

Ich benutze phpEd mit dem DBG... Jetzt habe ich (einer Version mit PHP 5.2.irgendwas) auf den aktuellen Xampp (mit php 5.3) upgedatet und der Debugger läuft nicht mehr...

Ich hab wie vorher auch die DLL in das ext Verzeichnis kopiert und folgendes in die php.ini eingetragen, unter xampp/php (könnte das daran liegen? vorher lag die glaube ich unter apache/bin)

Code: Select all
extension=dbg-php-5.3.dll
debugger.enabled = true
debugger.profiler_enabled = true
debugger.JIT_host = clienthost
debugger.JIT_port = 7869



Beim Hochfahren meckert er, dass irgendwelche Versionen da nicht übereinstimmen...
Ich hab mir auch schon die ältere Xampp-Version (1.72) gezogen, damit funzt es auch auch nicht

Code: Select all
PHP Warning:  PHP Startup: dbg: Unable to initialize module\nModule compiled with module API=20090115\nPHP    compiled with module API=20090626\nThese options need to match\n in Unknown on line 0
<br />
<b>Warning</b>:  PHP Startup: dbg: Unable to initialize module
Module compiled with module API=20090115
PHP    compiled with module API=20090626
These options need to match

(das war jetzt mit Xampp 1.7.2)

Wie finde ich die richtige PHP-Version? Irgendwie machen die Daten auch keinen Sinn. Für das Modul steht da 20090115, wenn ich mich recht erinnere, war php 5.3 da aber definitiv noch nicht draußen...

Vielen Dank
Gruß, Dave
http://www.2sound.de - das kostenlose Magazin für Musiker
D@ve
 
Posts: 29
Joined: 27. February 2005 14:17

Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest