Liegt es an der PHP Version?

Alles, was PHP betrifft, kann hier besprochen werden.

Liegt es an der PHP Version?

Postby kschroeder » 05. January 2010 12:01

Hallo,

Ich habe die aktuelle Version von Xampp heruntergeladen und installiert.
Enthalten ist ja PHP in Version 5.3.1.

Ich versuche nun das Modul php_saprfc_530.dll einzubinden und erhalte die folgende Fehlermeldung beim Starten vom Apache:

Unable to initialize module:
Module compiled with build ID API20090626,TS
PHP compiled with build ID API20090626,TS,VC6
These options need to match.

Wenn ich richtig verstanden habe, bedeutet die Angabe VC6, dass mit dem Visual Studio 6 Compiler kompiliert wurde??

Wie kann ich dann die Versionen zur Übereinstimmung bekommen?

Beim saprfc-Package gibt es auch eine php_saprfc_530_nts.dll. Da meckert Apache, dass das Modul gar nicht geladen werden könnte. Was auch immer hier wieder dieses "nts" zu bedeuten hat.
Eine ältere Version vom php_saprfc.dll, die mit php 5.2.4 lief, meldet Apache, dass die Anwedung erneut installiert werden sollte.

Wäre super, wenn mir hier jemand helfen könnte.
kschroeder
 
Posts: 251
Joined: 11. May 2007 13:33

Re: Liegt es an der PHP Version?

Postby Nobbie » 05. January 2010 14:44

kschroeder wrote:Enthalten ist ja PHP in Version 5.3.1.

Ich versuche nun das Modul php_saprfc_530.dll einzubinden


Offensicht ist diese DLL für PHP 5.3.0 gedacht, dann solltest Du auch PHP 5.3.0 installieren (Xampp 1.7.2).
Nobbie
 
Posts: 6770
Joined: 09. March 2008 13:04

Re: Liegt es an der PHP Version?

Postby Wiedmann » 05. January 2010 15:39

Code: Select all
Module compiled with build ID API20090626,TS

Da hat wohl jemand beim kompilieren der Extension nicht aufgepasst. Analog zur "PHP build ID" gehört auch hier ein ",VC6" oder ",VC9" hinten dran (je nach dem mit welchem Compiler die Extension gebaut wurde).

Um die Extension laden zu können, muss diese dann auf jeden Fall mit dem selben Compiler gebaut worden sein wie PHP. im Falle von XAMPP wäre das VC6.
(Ansonsten wurde die Extension ja für die korrekte PHP Version 5.3.x (API20090626) gebaut.)

Beides wäre dann ein Bug bzw. Frage an den Support von "php_saprfc".

Was auch immer hier wieder dieses "nts" zu bedeuten hat.

Non-Thread-Safe. Das PHP von XAMPP ist Thread-Safe (also TS).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Liegt es an der PHP Version?

Postby kschroeder » 05. January 2010 16:30

Ich bin da leider etwas unbedarft, aber inwiefern kann man beim Kompilieren nicht aufpassen und dann fehlt dieser Wert?
Ich hatte das jetzt so verstanden, dass die Extension eben weder mit dem einem noch mit dem anderen Compiler zusammengebaut wurde.
Ich verwende jetzt PHP schon seit Version 3 und die Extension seit PHP4 und bisher musste ich nur auf das Major-Release achten, nicht aber auf jedes Subrelease und noch weniger auf die Form und Art des Kompilers.

Ich werde wohl tatsächlich mal verschiedene PHP-Versionen ausprobieren müssen. Zunächst 5.3.0 und zur Not die bisher verwendete mit der bisherigen Extension.
kschroeder
 
Posts: 251
Joined: 11. May 2007 13:33

Re: Liegt es an der PHP Version?

Postby Wiedmann » 06. January 2010 00:07

Ich bin da leider etwas unbedarft, aber inwiefern kann man beim Kompilieren nicht aufpassen und dann fehlt dieser Wert?

Indem man nicht das normale Buildsystem für PHP benutzt, sondern z.B. ein dsp oder vcproj dafür benutzt, oder. einen Compiler wie MinGW oder Delphi und dann die zend_build.h nicht anpasst (bei den letztgenannten Compilern muss man das auch auf VC6 setzten).

Ich verwende jetzt PHP schon seit Version 3 und die Extension seit PHP4 und bisher musste ich nur auf das Major-Release achten,

Das war dann eher Glück ;-) Es hat schon immer die API Version von PHP und der Extension übereinstimmen müssen. Allzuhäufig ändert diese sich ja nicht. Das letzte mal eben mit PHP5.3.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Liegt es an der PHP Version?

Postby Fritz » 07. February 2010 16:40

Hallo Zusammen,

mit exakt der gleichen Problematik kämpfe ich. Jetzt habe ich nochmals XAMPP 1.7.2 installiert, weil dort PHP 5.3.0 und SAPRFC zusammen laufen sollen.

Ergebnis, das gleiche Problem.
Fritz
 
Posts: 2
Joined: 07. February 2010 13:20


Return to PHP

Who is online

Users browsing this forum: No registered users and 4 guests