PHP 5.3 Problem mit Joomla 1.5.14 oder downgrade auf PHP 5.2

Alles, was PHP betrifft, kann hier besprochen werden.

PHP 5.3 Problem mit Joomla 1.5.14 oder downgrade auf PHP 5.2

Postby MichaSt » 24. August 2009 17:13

HI,

ich habe gestern xampp 1.7.2 und Joomla 1.5.14 installiert und beim Starten meiner "website" wurden das Haupt- und das Schluesselkonzepte menu mit folgender Fehlermeldung angezeigt ->
Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in F:\xampp\htdocs\joomla\libraries\joomla\cache\handler\callback.php on line 99.

Ich habe dann ein bischen gesucht und hier, mehr oder weniger die Loesung gefunden... http://community.joomla.org/blogs/community/990-testing-help-with-php-530.html

Natuerlich kann und will ich nicht warten bis das Joomla Team die Loesung in der neuen Version eingebaut hat.

Nun zu meiner Frage wie kann ich in xampp von PHP 5.3 auf PHP 5.2 downgraden.

Danke schon mal im Vorraus fuer Eure Hilfe...

Micha
MichaSt
 
Posts: 3
Joined: 24. August 2009 16:45

Re: PHP 5.3 Problem mit Joomla 1.5.14 oder downgrade auf PHP 5.2

Postby MichaSt » 26. August 2009 01:34

;-) Hab mittlerweile ne Antwort gefunden, oder glaube ich zumindest...

http://forum.joomla.org/viewtopic.php?f=428&t=426456. Englisch

Aber die richtige Version zu finden, die die PHP Version < 5.3 hat, ist mir auch nicht so einfach gefallen. Der Link auf die Release Notes bei Sourceforge.net hat leider nur bei xampp Version 1.7.2 geklappt, aber nach ein "bischen" rumsurfen habe ich hier http://www.neurosoftware.ro/programming-blog/blogposter/web-resources/getting-started-with-magento-ecommerce/ rausgefunden das Version 1.7.0 http://sourceforge.net/projects/xampp/files/, zumindest die Lite Version, PHP 5.2.8 hat. Ich gehe mal davon aus das die "voll"-Version die gleiche Version hat.

Also alles deinstallieren und die Neue/Aeltere Version installieren...
MichaSt
 
Posts: 3
Joined: 24. August 2009 16:45

Re: PHP 5.3 Problem mit Joomla 1.5.14 oder downgrade auf PHP 5.2

Postby Nobbie » 26. August 2009 10:26

Also ich habe gestern Joomla unter PHP 5.3 problemlos installiert. Die Warnungen kann man entweder im Sourcecode beheben, oder einfach in php.ini den Errorlevel so setzen, dass sie nicht ausgegeben werden.

Das ist alles, was man machen muss - extrem einfach und schnellstens erledigt.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: PHP 5.3 Problem mit Joomla 1.5.14 oder downgrade auf PHP 5.2

Postby MichaSt » 26. August 2009 12:54

Hi Nobbi,

Danke fuer die Antwort... aber leider bin ich noch recht neu in der Sache und habe nicht besonders viel Erfahrung in website Entwicklung und das dazugehoerige know how. Aber ich bin ja jetzt dran...;-)
Hab jetzt die 1.7.0 installiert und es laeuft.... Ich denke fuers erste reicht es fuer mich...
MichaSt
 
Posts: 3
Joined: 24. August 2009 16:45


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest