VISTA and XAMPP blank page issue

Alles, was PHP betrifft, kann hier besprochen werden.

VISTA and XAMPP blank page issue

Postby sorindoru » 06. March 2009 17:52

Hello,
I really want to learn php. I am a beginner, and I need to practice. I am running VISTA, ver 6, sp1 and XAMPP 1-70. I have installed XAMPP in C:\xampp
I practice learning in this way: I create a separate folder in htdocs, and name it "test.php".
I write the code down, and use notepad++ for that. I save the file, and then I load the file in Firefox.
It worked 2 days ago, but now I don't know what happened. It doesn't load the file in Firefox. It's just a blank screen, even if I write down some code like <?php echo"Hello world" ?>
I uninstalled XAMPP and reinstalled it back again. I am using the latest XAMPP, for win32 ver 1-70 . Same issue.
I've realized these problems appeared after I put the laptop on Hibernate. Even with restart, it doesn't work anymore.
Please, help me to fix it.
Or, just tell a website where I could have a sandbox to play around.

Danke schon,
sorindoru
 
Posts: 4
Joined: 06. March 2009 17:39

Re: VISTA and XAMPP blank page issue

Postby Wiedmann » 06. March 2009 18:02

and then I load the file in Firefox.

How are you doing this exactly.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: VISTA and XAMPP blank page issue

Postby sorindoru » 06. March 2009 19:27

CTRL+O and then get the file from the hard drive location, or drag and drop.
Same thing. Same issue.
sorindoru
 
Posts: 4
Joined: 06. March 2009 17:39

Re: VISTA and XAMPP blank page issue

Postby Wiedmann » 06. March 2009 19:59

get the file from the hard drive location, or drag and drop.

You must open PHP files with "http://..." in the address bar.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: VISTA and XAMPP blank page issue

Postby sorindoru » 06. March 2009 21:38

I copy & paste the following address in the browser:
file:///C:/xampp/htdocs/invat/
and I can see the file "test.php" in the browser. So I click it, and the new address is file:///C:/xampp/htdocs/invat/test.php

If I am not running my php file on the web, and I run it locally with XAMPP, how could i have the "http" in the address?

if I write "localhost" in firefox address, it automatically redirects me to http://localhost/xampp/

How could I find the http address of the file test.php ?
sorindoru
 
Posts: 4
Joined: 06. March 2009 17:39

Re: VISTA and XAMPP blank page issue

Postby sorindoru » 17. March 2009 20:55

sorindoru wrote:I copy & paste the following address in the browser:
file:///C:/xampp/htdocs/invat/
and I can see the file "test.php" in the browser. So I click it, and the new address is file:///C:/xampp/htdocs/invat/test.php

If I am not running my php file on the web, and I run it locally with XAMPP, how could i have the "http" in the address?

if I write "localhost" in firefox address, it automatically redirects me to http://localhost/xampp/

How could I find the http address of the file test.php ?


Weeeeeeeeeeeeeeeee!
I finally got it! Thanks, Wiedmann, you were right about the opening files with "http". The mistake was: I used to open files with "file:///C:/xampp/htdocs/invat/test.php"

But the correct way to open the file was "localhost/invat/test.php" or " http://127.0.0.1/invat/test.php "

I tried a lot of combinations, but got stuck with mistakes like: "http://127.0.0.1/xampp/htdocs/invat/test.php" .

So, again, problem solved. It took me a while.

Thanks again, Wiedmann!
sorindoru
 
Posts: 4
Joined: 06. March 2009 17:39


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests