How Can I Upgrading php 4.4.1 to php 5.2.4

Alles, was PHP betrifft, kann hier besprochen werden.

How Can I Upgrading php 4.4.1 to php 5.2.4

Postby Gabriel Vega » 10. December 2008 20:25

Hi

I Use xampp 1.6.8 because I'm a Joomla developer but nowadays y need to run a application that was made in php 4.4.1 but I have the next errors:

Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

When I change status warnings in session.bug_compat_42 = 0 and session.bug_compat_warn = 0, the message disapear but php didn´t recognice the user and password.

I switch php in xampp to php 4 but the application didn´t work.

Do you know how Can I fix it?

My best Regards

Gabriel Vega. :roll: :roll:
Gabriel Vega
 
Posts: 1
Joined: 10. December 2008 20:09

Re: How Can I Upgrading php 4.4.1 to php 5.2.4

Postby Wiedmann » 10. December 2008 20:39

Do you know how Can I fix it?

Ask the application developers (Joomla makers) what is the correct PHP setting for this software? Or better ask the Joomla developers to correct their code (and don't use this special bug/feature from PHP).

When I change status warnings in session.bug_compat_42 = 0 and session.bug_compat_warn = 0, the message disapear but php didn´t recognice the user and password.

I guess you don't want see the message, but you want allow the script to use this bug:
Code: Select all
session.bug_compat_42 = On
session.bug_compat_warn = Off
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests