mysteriöser fehler

Alles, was PHP betrifft, kann hier besprochen werden.

mysteriöser fehler

Postby ruudi » 03. June 2008 10:17

hi,

baue meine seite mittels verschiedener includes auf. das ganze sieht dann so aus:

<?php
require(".\_includes\PageElements\header.inc");
?>

<?php
/* beim ersten aufruf der seite ohne parameter wird die
indexseite ausgegeben
ansonsten die dem parameter $kategorie entsprechende seite */
if(!isset($kategorie))
{
require("_index.php");
}else{
require("_" . $kategorie . ".php");
}
?>

<?php
require(".\_includes\PageElements\footer.inc");
?>

beim letzten require-befehl tritt nun folgendes problem auf:
unter php4 läuft alles unter php5 kommt folgende warnmeldung

Warning: require(.\_includes\PageElements ooter.inc) [function.require]: failed to open stream: Invalid argument in C:\xampp\htdocs\fastenportal\index.php on line 20

Fatal error: require() [function.require]: Failed opening required '.\_includes\PageElements ooter.inc' (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\fastenportal\index.php on line 20

das mysteriöse daran ist, dass wenn ich statt footer.inc irgendetwas anderes einsetze (bsp-weise klaus.inc), dann läuft es. offensichtlich
scheint php5 ein problem mit dem buchstaben f zu haben.

vielleicht ist ja schon mal einer auf dieses problem gestoßen und kann mir mit einem tip weiterhelfen. dabei wäre mir an echten problemlösungshinweisen gelegen. auf die idee die datei einfach in klaus umzubenennen bin ich nämlich auch schon gekommen ;-)

danke r.
ruudi
 
Posts: 1
Joined: 03. June 2008 10:01

Postby sari42 » 03. June 2008 10:23

versuch's mal mit forward slashes ("/" statt "\") ...
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to PHP

Who is online

Users browsing this forum: No registered users and 4 guests