gettext

Alles, was PHP betrifft, kann hier besprochen werden.

gettext

Postby markao » 11. February 2003 15:23

hi,

bin wirklich gespannt, ob das die HORDE zum laufen bringt....

Habe gerade eben erfolgreich gettext installiert, weil ich annahm, es liege am fehlen des entsprechenden moduls libintl.so.2, das ich als gettext-bestandteil identifizieren konnte.

Und zwar habe ich es installiert mit folgender Option:

./configure '--prefix=/opt/lampp'

Hoffentlich kein Fehler?

ciao Markus
markao
 

Postby Oswald » 11. February 2003 15:36

Huhu Markao!

Ja, es fehlt nur diese libintl. Wenn Du Dir gettext installiertst, dann solltest Du dadurch die fehlende Datei auch bekommen und PHP sollte funktionieren.

Der configure sieht gut aus. Genau so und dann make und danach make install.

Viel Erfolg!!!

Gruß,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

fehlanzeige

Postby markao » 11. February 2003 17:48

hi oswald,
leider nein - zwar wurde gettext erfolgreich installiert (whereis zeigt jetzt im verzeichnis /opt/lampp/bin/gettext), aber wenn ich mit "find / libintl.so.2 suche (oder auch mit libintl*), so bekomme ich fehlanzeige - ein solches teil gibt es nicht.
womöglich handelt es sich ja nur um eine routine und die wird nicht gefunden, weil der pfad nicht stimmt? auf dem selben rechner befindet sich gettext ja schon einmal von der suse-distri...
hm... wenn du mir also den korrekten file mit php doch noch hochladen könntest - ich wäre überglücklich, wenn ich dieses kapitel endlich abschliessen könnte.
ciao markao
markao
 

einen schritt weiter, aber noch nicht am ziel

Postby markao » 11. February 2003 18:45

hi,

die libintl.so.2 habe ich mittlerweile in /opt/lampp/lib/ untergebracht - aber jetzt wird ein symbol angemeckert... vermutlich findet lampp einfach das gettext-verzeichnis nicht?

hier die neueste fehlermeldung:


Starting LAMPP 0.9.7...
LAMPP: Starting Apache with SSL...
Syntax error on line 230 of /opt/lampp/etc/httpd.conf:
Cannot load /opt/lampp/modules/libphp4.so into server: /opt/lampp/modules/libphp4.so: undefined symbol: libintl_bindtextdomain
LAMPP: Error 1! Couln't start Apache!
LAMPP: Starting MySQL...
LAMPP: Starting ProFTPD...
LAMPP started.


vermutlich führt doch kein weg daran vorbei, gettext mit in php hineinzukompilieren...

Ciao Markus
markao
 

nach gettext update glibc neu kompilieren?

Postby markao » 11. February 2003 22:02

hi,

irgendwo hab ich nen hinweis gefunden, nach einem gettext-update müsse man glibc neu kompilieren... das ist wohl wie mit einem stein, den man ins wasser wirft - zieht immer weitere kreise.

macht dieser weg noch sinn?

ich hoffte, lampp würde die kompilierarbeit beim updaten der versionen abnehmen - und bin jetzt genauso schlau als wie zuvor.

ciao markao
markao
 

Postby Oswald » 12. February 2003 01:51

Huhu Markao!

Sorry. Alter Mann kein D-Zug. Ich versuch Dir ja die Compilearbeiten abzunehemen, aber wenn Du mir keine Zeit dazu lässt... ;)

Die PHP-mit-gettext-Datei ist jetzt aber online:

http://prdownloads.sourceforge.net/xamp ... z?download

Ich hoffe es klappt jetzt!!

Viele Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

gettext ok WOW !!! aber: PEAR...

Postby markao » 12. February 2003 09:41

hi oswald,

ich bin begeistert: es sieht so aus als wäre das die schlussgerade...

ein kleiner fehler steckt aber anscheinend noch im system - und ich habe den eindruck, dass das eher an LAMPP als an HORDE liegt.

horde startet bereits, meldet sich dann aber mit einer php-fehlermeldung, dass die datei log.php nicht aufgerufen werden könne.

tatsächlich bekomme ich auch mit der test.php von HORDE folgende fehlermeldung:


PEAR

[color=blue] * PEAR -
Yes
* Recent PEAR - Yes
* Mail::RFC822 - Yes
* Log - No
* Make sure you're using a recent version of PEAR which includes the Log class.

* DB - Yes

bedeutet dies, dass ein neueres PEAR zu installieren ist?
oder deutet es eher auf einen internen HORDE fehler (etwa eine fehlende log-datei oder pfadangabe zur logdatei) hin?

ich habe eher den eindruck, dass es PEAR selbst ist, was zu aktualisieren ist, aber in der zweiten zeile heisst es allerdings "Recent PEAR - Yes"...

was meinst du?

und: noch ein ganz dickes dankeschön!
jetzt bin ich wieder zuversichtlich, dass der rest auch noch zu schaffen ist.

gruesse
markao
markao
 

Nachtrag: PEAR & php.log

Postby markao » 12. February 2003 09:56

Nachtrag:

Es sieht in der tat danach aus, als ob es sich um ein fehelndes paket von PEAR handelt.

Die fehlermeldungen von php (beim aufruf der HORDE-Seite) lauten nämlich wie folgt:


Warning: logmessage(Log.php) [function.logmessage]: failed to create stream: Datei oder Verzeichnis nicht gefunden in /opt/lampp/htdocs/horde/lib/Horde.php on line 145

Warning: logmessage() [function.logmessage]: Failed opening 'Log.php' for inclusion (include_path='.:/opt/lampp/lib/php') in /opt/lampp/htdocs/horde/lib/Horde.php on line 145

Fatal error: Undefined class name 'log' in /opt/lampp/htdocs/horde/lib/Horde.php on line 155


Nach anlegen einer Datei "Log.php" in /opt/lampp/lib/php reduziert sich die fehlermeldung auf den letzten teil "Fatal error: Undefined class name 'log' in ...".

Hierzu habe ich folgenden hinweis in der FAQ von HORDE gefunden:


5.1.21 "Fatal error: Undefined class name 'log' in ..."

[Horde 2.x]: Your PHP PEAR implementation is missing the PEAR Log package. This is a common problem with the PHP 4.2.1 PEAR for example. You can install it via the network if you have a standalone php/pear command. See the file horde/docs/INSTALL for more information on how to install the required PEAR packages this way. Otherwise you can download the Log package (e.g. from http://pear.php.net/get/Log) and manually install them inside your PEAR directory. You may also need to install the modules Mail_Mime and Net_Socket as well.

For more detailed instructions on install PEAR modules, see the PEAR documentation at http://pear.php.net/manual/.


Mal sehen, ob das problem damit zu lösen ist...

ciao markao
markao
 

PEAR doch problem von LAMPP?

Postby markao » 12. February 2003 10:27

Hi,

in der FAQ von HORDE wird eine installationsanleitung für HORDE angegeben, in der ich folgenden hinweis für PEAR gefunden habe:


This method of installing PEAR modules requires that your PHP has
been compiled as a static binary. If you installed PHP as a webserver
module, recompile PHP without the module option (for Apache, without
BOTH --with-apache and --with-apxs) and do a 'make install'.


ich probier noch, ob ich das paket Log auch so nachinstallieren kann, aber ein wenig sieht es danach aus als ob HORDE ein PHP mit statischem PEAR benötigen würde...

was dann?

ciao markao
markao
 

PEAR & Log

Postby markao » 12. February 2003 11:03

hi,

habe das paket Log (wie in der FAQ von HORDE, s.o.) heruntergeladen und das verzeichnis /Log manuell ins verzeichnis kopiert, in dem sich auch pear befindet (/opt/lampp/bin/). Allerdings meldet "pear install Log", dass sich Log nicht öffnen lasse.

Ausserdem habe ich die datei Log, die mit ausgepackt wurde, dorthin kopiert, wo sie von voriger fehlermeldung reklamiert wird (s.o.). Diese datei sorgt anscheinend dafür, dass die test.php nunmehr ausgibt, dass Log installiert sei (d.h. es gibt nur noch grüne ok-meldungen).


Die neueste fehlermeldung ist nun folgedne:

Ein schwerer Fehler ist aufgetreten:

An error has occurred. Furthermore, Horde encountered an error attempting to log this error.

[Zeile 162 von /opt/lampp/htdocs/horde/lib/Horde.php]


Was nun?

ciao markao
markao
 

Ende der Fahnenstange

Postby markao » 12. February 2003 11:37

Hi,

es hilft anscheinend nichts: da die pear-module für HORDE benötigt werden, ist PHP ohne dynamisches pear-modul zu kompilieren und PEAR anschliessend statisch zu installieren.

ob so viel aufwand sich noch rechtfertigen lässt?

kopfzerbrechen macht mir obendrein, dass PEAR ja schon bei der SuSE 8.0 mit dabei ist - und dass sich die beiden installationen beim aufruf von pear anscheinend in die quere kommen, obwohl ich pear extra vom entsprechenden lampp-verzeichnis aus aufgerufen habe.


Hier die kompletten hinweise der HORDE-anleitung:

These PEAR modules are REQUIRED to be installed for complete Horde functionality:

a. Log

To install, you must enter the following at the command prompt:
pear install Log

b. Mail_Mime

To install, you must enter the following at the command prompt:
pear install Mail_Mime

These PEAR modules are RECOMMENDED to be installed:

a. File

REQUIRED only if you wish to import CSV files.
To install, you must enter the following at the command prompt:
pear install File

b. Date

REQUIRED only if you are dealing with calendar data.
To install, you must enter the following at the command prompt:
pear install Date

This method of installing PEAR modules requires that your PHP has
been compiled as a static binary. If you installed PHP as a webserver
module, recompile PHP without the module option (for Apache, without
BOTH --with-apache and --with-apxs) and do a 'make install'.


ziemlich enttäuscht, so kurz vor knapp doch noch zu scheitern...

ciao markao
markao
 

uff... /opt/lampp/bin/pear intall [paket] muss es heissen!

Postby markao » 12. February 2003 11:44

hi,

anscheinden hilft es, wenn es einen ort gibt, mit dem ich dialog führen kann: jetzt bin ich meinem fehler selbst auf die schliche gekommen - es genügt nicht, einfach nur im verzeichnis zu sein, in dem sich das lampp-pear befindet - es muss der komplette pfad bis zum command angegeben werden, also:

/opt/lampp/bin/pear install Log

Und siehe da: die installation hat den fehler beseitigt.

jetzt gibt es noch ein kleines db-problem - aber das sieht mir schon aus wie der durchbruch...

ciao markao :)
markao
 

Postby Oswald » 12. February 2003 14:53

Huhu Markao!

Ah.. super, dass jetzt so langsam alles bei Dir läuft.

Aber noch ein kleiner Hinweis: Wenn Du ein PEAR-Paket installieren möchtest, dann geht das ganz einfach. Zum Beispiel für die vier Pakete die Du oben erwähnt hast. Einfach nach einander aufrufen:

/opt/lampp/bin/pear install Log
/opt/lampp/bin/pear install Mail_Mime
/opt/lampp/bin/pear install File
/opt/lampp/bin/pear install Date


Dann hast Du auch nicht das Problem, dass Du nicht weisst wohin was soll, weil dann geht's automatisch! ;)

Viele Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux


Return to PHP

Who is online

Users browsing this forum: No registered users and 6 guests