wie kompiliere ich PHP mit gettext neu?

Alles, was PHP betrifft, kann hier besprochen werden.

wie kompiliere ich PHP mit gettext neu?

Postby markao » 10. February 2003 19:49

Hi,

(dies habe ich versehentlich unter "rund um lampp" gespostet - hier ist es wohl besser aufgehoben)

Ich möchte unbedingt HORDE mit LAMPP zum laufen bekommen.
Leider gibt es jedoch gleich auf der Startseite eine Fehlermeldung von PHP.

Ich habe von jemandem aus der HORDE-NewsGroup einen Hinweis bekommen, man müsse gettext in PHP kompilieren:


5.1.18 "Call to undefined function: _( )" [Horde 2.0]

Horde 2.0]: This error occurs when PHP is not compiled with gettext support. As of version Horde 2.0, PHP needs to be compiled with gettext support. Rebuild PHP with the --with-gettext option to configure, or if using RPM's install the php-gettext RPM. (_() is a synonym for gettext() in PHP.)


Wie mach ich das mit LAMPP? Kann ich PHP4 einfach neu kompilieren oder was much ich dabei beachten?

Gruesse
Markao
markao
 

Postby Oswald » 10. February 2003 23:40

Huhu Markao!

Leider ist es schon recht schwierig PHP selbst zu übersetzen und mindestens ebenso schwierig ist es, das zu beschreiben bzw. zu erklären.

Ich hab's mir und Dir deswegen mal einfacher gemacht und ein kleines "Upgrade" für LAMPP 0.9.7 zusammengestellt. Es enthält nur ein PHP mit GNU gettext Unterstützung und installiert sich mit folgendem Befehl:

tar xvfz lampp-phpwgettext-0.9.7.tar.gz -C /opt

Herunterzuladen gibt's das Ganze unter
http://prdownloads.sourceforge.net/xampp/lampp-phpwgettext-0.9.7.tar.gz?download

Ich konnte die gettext-Unterstützung nicht wirklich testen. Aber es sollte so funktionieren.

Viel Erfolg,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

wow...

Postby markao » 11. February 2003 12:08

hi, oswald,

du bist genial - oder sagen wir: fast genial (aber schon ziemlich dicht dran):


Starting LAMPP 0.9.7...
LAMPP: Starting Apache with SSL...
Syntax error on line 230 of /opt/lampp/etc/httpd.conf:
Cannot load /opt/lampp/modules/libphp4.so into server: libintl.so.2: cannot open shared object file: No such file or directory
LAMPP: Error 1! Couln't start Apache!
LAMPP: LAMPP-MySQL is already running.
LAMPP: LAMPP-ProFTPD is already running.
LAMPP started.


Sieht eigentlich recht harmlos aus, oder?
Verzeichnis anlegen? Irgendein teil hineinkopieren?
Im moment geht wohl gar nichts.

Ein ganz dickes dankeschön schon einmal!
Ich bin super gespannt... wenn es das nur wäre!

Markao
markao
 

Postby Oswald » 11. February 2003 14:46

Huhu Markao!

Mist. Source Forge. Ich hatte die Datei vorher schon mal felherhaft hochgeladen und dann noch mal ersetzt. Du hast jetzt die fehlerhafte Datei bekommen. Äh.. nein die sind alle falsch. Hmm.. ich befürchte ich hab beim zweiten Hochladen auch noch mal die falsche Datei hochgeladen. :oops:

Heute Abend kommt die richtige Datei da hin. Ich werd hier noch mal ankündigen. Bis dahin nehm ich die fehlerhafte Datei vom Server.

Sorry!!

Liebe Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

gettext, die zweite

Postby markao » 11. February 2003 15:29

hi,

es ist ein bisschen viel verlangt, eine message eindeutig zu posten :?
Man muss nämlich knöpfe lesen bevor man sie drückt...
Sorry, habe gerade ein neues thema "gettext" eröffnet, anstatt eine antwort abzusenden (knirsch).

markao
markao
 


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests