gdlib funktionsproblem

Alles, was PHP betrifft, kann hier besprochen werden.

gdlib funktionsproblem

Postby the thing » 23. August 2007 16:35

Hallo!

Ich habe in meinem apachen php5 und die GD lib mit freetype support laufen, dennoch funktioniert ein altes script von mir nicht mehr, welches einen text in ein Bild geschrieben hat ...

Mir ist aufgefallen das das Problem aber nicht bei der GD Lib selber liegt sondern bei speziell der funktion ImageTTFtext, welche halt einen
String in einen Picture Handle schreiben kann ...

phpinfo sagt:

gd
GD Support enabled
GD Version 2.0 or higher
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.2.1
T1Lib Support enabled
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled


dennoch funktioniert dieses exemplarische script nicht:

<?php
Header ("Content-type: image/jpeg");
$im = imagecreate (400, 30);
$black = ImageColorAllocate ($im, 0, 0, 0);
$white = ImageColorAllocate ($im, 255, 255, 255);
ImageTTFText ($im, 20, 0, 10, 20, $white, "arial.ttf",
"Teste... Omega: Ω");
ImageJpeg ($im);
ImageDestroy ($im);
?>


siehe: http://serjoscha.hopto.org:100/imagettf ... script.php

Mich würde jetzt interessieren wieso das ganze nicht funktioniert.
Kann mir darüber jemand eine Auskunft geben ?

Mich verwirrt übrigens auch das ich noch mit gifs arbeiten kann obwohl der support dafür ja eigentlich raus sein sollte ...

Danke im voraus, liebe grüße
"Wissen ist der größte Reichtum und Ignoranz zeugt von Armut" - Ali ibn Abi-Talib
the thing
 
Posts: 39
Joined: 26. December 2005 18:47

Postby Wiedmann » 23. August 2007 16:41

Mich würde jetzt interessieren wieso das ganze nicht funktioniert.

Steht doch in der Fehlermeldung von PHP?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby the thing » 23. August 2007 16:43

nein der fehler liegt nicht auf seitens des scripts ..
das script habe ich vorher ca n jahr in einer foren signa gehabt ...
bzw das bild was es erzeugt hat .. und jetzt funktioniert es nicht mehr ..
das problem liegt irgendwo bei der imagettftext funktion der neuen GD lieb
die ich seit der reinstallation des servers habe ...
"Wissen ist der größte Reichtum und Ignoranz zeugt von Armut" - Ali ibn Abi-Talib
the thing
 
Posts: 39
Joined: 26. December 2005 18:47

Postby Knight1 » 24. August 2007 14:04

the thing wrote:nein der fehler liegt nicht auf seitens des scripts ..
das script habe ich vorher ca n jahr in einer foren signa gehabt ...
bzw das bild was es erzeugt hat .. und jetzt funktioniert es nicht mehr ..
das problem liegt irgendwo bei der imagettftext funktion der neuen GD lieb
die ich seit der reinstallation des servers habe ...


Dann lese Dir mal die allereste Zeile in der Ausgabe durch. Da steht genau drin was schief läuft.


Kai aka Knight1
Image
User avatar
Knight1
 
Posts: 310
Joined: 18. October 2003 10:03
Location: Trier
Operating System: Windows 7 Ultimate x64

Postby the thing » 24. August 2007 22:39

ja wie
"http://serjoscha.hopto.org:100/imagettftext_bug/script.php"

mehr steht da doch nicht o.O

oder welche ausgabe meinst du ?
"Wissen ist der größte Reichtum und Ignoranz zeugt von Armut" - Ali ibn Abi-Talib
the thing
 
Posts: 39
Joined: 26. December 2005 18:47

Postby KingCrunch » 25. August 2007 05:03

Wenn es nicht funktioniert, passiert ja irgendetwas "statt dessen", im besten (und normalerweise üblichen) Fall eine Fehlermeldung! Darauf wollen die ganzen Leuten hinaus ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby the thing » 25. August 2007 10:15

naja gut aber da ist nunmal keine fehlermeldung und sowas wie mysql_error() gibts wohl für die gd lib nicht ^^
"Wissen ist der größte Reichtum und Ignoranz zeugt von Armut" - Ali ibn Abi-Talib
the thing
 
Posts: 39
Joined: 26. December 2005 18:47

Postby Wiedmann » 25. August 2007 10:29

naja gut aber da ist nunmal keine fehlermeldung

Natürlich ist da eine. Sonst könnte ich ja auch nicht schreiben:
the thing wrote:Mich würde jetzt interessieren wieso das ganze nicht funktioniert.
Wiedmann wrote:Steht doch in der Fehlermeldung von PHP?


Aber um das mal abzukürzen...
Wenn man:

diese URI aufruft, erhält man diese Antwort und Fehlermeldung vom deinem Server:
Warning: imagettftext() function.imagettftext]: Could not find/open font in /var/www2/imagettftext_bug/script.php on line 7
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby the thing » 25. August 2007 11:16

okay das finde ich jetzt mal sehr interessant

http://server:100/imagettftext_bug/noerror.jpg

wieso zum henker kann ich den fehler nicht sehen ?

*edit

wtf .. der IE gibt mir auch den von dir genannten fehler aus ... nur der FF nicht .. -_-'

auf sowas soll mal jemand kommen ..

aber das ist eigentlich typisch für den IE .. der FF sieht durchs setzen des header types das es n bild ist und hält konsequent html/plaintext ausgaben aus der ausgabe durch die r ender engine raus .. der ie ignoriert das es n eigentlich vom typen image ist und zeigt einfach ascii zeichen an ... naja .. an der stelle vllt ein ganz nützlicher bug ..

*edit 2

hm okay jetzt funktionierts .. ich habe aus 'arial.ttf' -> './arial.ttf' gemacht -_-

*edit 3

okay es lag einzig und allein an dem ./ vor dem font namen ...
skurril .. früher war das nicht so ... ich habe das script sos lange ohne ./ benutzt .. naja, jetzt funktioniert es.
Danke für die hinweise =)

btw ... der gif support ist ja tatsächlich noch drin o.ô
"Wissen ist der größte Reichtum und Ignoranz zeugt von Armut" - Ali ibn Abi-Talib
the thing
 
Posts: 39
Joined: 26. December 2005 18:47


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests