php_ldap.dll wird nicht geladen

Alles, was PHP betrifft, kann hier besprochen werden.

php_ldap.dll wird nicht geladen

Postby endor » 13. July 2007 08:27

Hallo,

ich habe XAMPP 1.6.2. auf Windows installiert und möchte jetzt für die MediaWiki LDAP Authentifizierung die php_ldap.dll laden. Dazu habe ich sie in der php.ini einkommentiert und XAMPP vollständig neu gestartet. Ich sehe keine Fehlermeldungen (wo kann ich eigentlich nach PHP Fehlermeldungen suchen?). Wenn ich eine PHP LDAP Funktion aufrufe wird gesagt sie existiert nicht und phpinfo() zeigt auch an, dass es keine LDAP Funktionalität in PHP gibt. Ist alles mit der Bibliothek in Ordnung? Kann ich irgendwie rausfinden, was schief gelaufen ist?
endor
 
Posts: 2
Joined: 13. July 2007 08:23

Postby Wiedmann » 13. July 2007 12:01

Dazu habe ich sie in der php.ini einkommentiert

Das war auch die richtige "php.ini"?
--> siehe phpinfo()
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby endor » 16. July 2007 07:15

Oh. Danke für den Hinweis. Inwiefern ist es sinnvoll da zwei mitzuliefern?
endor
 
Posts: 2
Joined: 13. July 2007 08:23

Postby KingCrunch » 16. July 2007 07:40

Wenn ich mich recht entsinne war ine für PHP als Cli und eine, als Modul/Cgi. Kann aber auch sein, dass eine für PHP4 is ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests