sendmail doesnt work with PHP5 (PHP switch)

Alles, was PHP betrifft, kann hier besprochen werden.

sendmail doesnt work with PHP5 (PHP switch)

Postby roeland » 12. June 2007 23:26

Hi,

I have the following problem.
We use webforms. When we use php4 everything works well.
But when we switch to php5. The sendmail doesn t seem to work.
We get a confirmation that everything seems to be allright because the webform closes, but the email will never be posted.

Does anybody have a solution?

Roeland

-------------------------------------

Guten tag,

I habe ein problem.
Wir haben webforms. Mit PHP4 ist alles gute, aber als wir PHP5 installieren (PHP switch), dann konnen wir kein email senden. Das email kommt nicht an!

Kann jemand mir helfen?

Roeland
roeland
 
Posts: 2
Joined: 12. June 2007 23:10

Postby kschroeder » 14. June 2007 15:20

I think, although you use the php switch to switch between php4 and php5 you have to edit the php.ini for php5 too.

Just take a take a look into the right php.ini (using xampp it's normally located here: ...apache/bin/)

Btw. we have a special board area for all english fans of xampp. ;)
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

thanks but a have allready looked there.

Postby roeland » 14. June 2007 17:19

I have allready modified that php.ini file but it still doesn t work. Do you have more suggestions?
roeland
 
Posts: 2
Joined: 12. June 2007 23:10

Postby kschroeder » 15. June 2007 08:05

Do you get an error message? You may have such a message in the apache or php logs.

Could you try the sendmail with a short test script? Make sure you don't use any '@' in front of a command.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest