PHP läuft nicht - HTTP Error 500

Alles, was PHP betrifft, kann hier besprochen werden.

PHP läuft nicht - HTTP Error 500

Postby real.bastie » 07. May 2007 11:03

Hallo,

ich habe ein kleines Problemchen. Ich habe PHP durch
Code: Select all
ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php
AddType application/x-httpd-php .php3
AddType application/x-httpd-php .php4
Action application/x-httpd-php "/php/php.exe"

in der conf Datei eingebunden. Beim Start einer PHP Seite bringt er immer 500 Internal Server Error und verweist auf die Log-Datei:
Code: Select all
[Mon May 07 12:01:19 2007] [error] [client 127.0.0.1] Premature end of script headers: php.exe, referer: http://localhost

bringt mir aber nicht viel. Ich habe schon gegoogled aber entweder 0 Treffer oder eine gute 6stellige Zahl...

In der Hoffnung auf Hilfe
real.bastie
 
Posts: 7
Joined: 07. May 2007 10:54

Postby Wiedmann » 07. May 2007 12:22

Action application/x-httpd-php "/php/php.exe"

"php.exe" ist das CLI-Binary. Du willlst doch aber bestimmt das CGI-Binary "php-cgi.exe" benutzen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Danke

Postby real.bastie » 07. May 2007 14:00

Ja, das war's - da ich mit Perl das gleiche Problemchen habe werde ich mal schauen ob es da auch eine CGI Version gibt.
real.bastie
 
Posts: 7
Joined: 07. May 2007 10:54

Postby Wiedmann » 07. May 2007 14:22

da ich mit Perl das gleiche Problemchen habe

Dann wird dein Perl-Script die notwendigen Header nicht ausgeben.

werde ich mal schauen ob es da auch eine CGI Version gibt.

Gibt es nicht.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

shit

Postby real.bastie » 07. May 2007 14:49

Ich stelle es trotzdem mal ins Perl Forum und BETE
real.bastie
 
Posts: 7
Joined: 07. May 2007 10:54


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest