Beim Aufrufen der Dateien krieg ich keine Fehlermeldungen.

Alles, was PHP betrifft, kann hier besprochen werden.

Beim Aufrufen der Dateien krieg ich keine Fehlermeldungen.

Postby JeJo » 14. April 2007 00:08

Hallo alle,

hab mir heute XAMPP neu runtergeladen und mich gleich drauf losgestürzt. Funktionier auch alles super toll, nur ein Problem hab ich.
wenn ich die Datei dann aufrufen will und ich hab mich irgendwo vertippt oder ähnliches kommt meistens nur ein leeres browserfenster.
Also keinerlei Fehlermeldung, woran es liegt.

Ein Beispiel dafür:

echo "Die Summe von $_POST['w1'] und $_POST['w2'] ist $erg";

funktioniert bei mir nicht (ich weiß auch warum).
Bei mir erscheint da nur ein leerer Bildschirm.
Bei nem Kumpel, der ne ältere Version hat erscheint ne Fehlermeldung von der Art:

"POST Variablen können nicht in echo gepackt werden" (frei übersetzt)

Ich habs dann geändert in

echo "Die Summe von " . $_POST['w1'] . " und " . $_POST['w2'] . " ist $erg";

Damit geht es auch ohne probs, nur dass ich selber keinerlei Hinweise kriege warum es nicht funktioniert und damit kann es schon extrem schwierig werden, vernünftig was zu programmieren ;)

Wenn jmd nen Rat hätte, wäre ich sehr dankbar.

MfG

JeJo
JeJo
 
Posts: 2
Joined: 13. April 2007 23:59

Postby Wiedmann » 14. April 2007 12:38

Wie ist denn "display_errors" und "error_reporting" bei dir eingestellt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JeJo » 15. April 2007 22:11

Problem hat sich erledigt, hatte vor xampp ein anderes php installiert und er hat die php.ini benutzt. Somit wurden nicht die Standardeinstellungen von xampp benutzt. Hab die "falsche" jetzt mit der richtigen ersetzt und schon klappt alles.
Danke für die Hilfe.

JeJo
JeJo
 
Posts: 2
Joined: 13. April 2007 23:59


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest