PHP Cli Installieren

Alles, was PHP betrifft, kann hier besprochen werden.

PHP Cli Installieren

Postby root_ » 06. April 2007 09:41

Wie kann ich noch (bei XAMPP) zusätzlich das PHP-CLI aktivieren/installieren ?

Wahrscheinlich muss ich PHP neu komplimieren... entstehen eigentlich dabei irgendwelche Probleme ?

Vielen Dank.

cu
root_
 
Posts: 6
Joined: 06. April 2007 09:38

Postby Wiedmann » 06. April 2007 10:22

IMHO ist das dabei.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby root_ » 06. April 2007 16:21

Danke.

Nun will ich einen Script installieren, in dem das PHP-CLI nötig ist.

"PHP Kommandozeilen Unterstzützung:
(nicht gefunden)

Die Kommandozeilen Variante von PHP wurde nicht gefunden. Bitte stellen Sie sicher das php-cli installiert ist UND ob das mysql.so in der entsprechenden php.ini aktiviert ist."

Was soll ich nun tun ??

MFG
root_
 
Posts: 6
Joined: 06. April 2007 09:38

Postby Wiedmann » 06. April 2007 16:32

Das solltest du den Hersteller dieses Scriptes fragen...

(Dieses sucht jedenfalls an der falschen Stelle nach dem CLI.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby root_ » 06. April 2007 16:34

Ok.

Aber wie kann man eigentlich das mysql.so in der php.ini aktivieren ?

mfg
root_
 
Posts: 6
Joined: 06. April 2007 09:38

Postby Wiedmann » 06. April 2007 16:43

Eine Shared-Extension wird über "extension=foo.so" aktiviert.

Beim XAMPP sind die aber eh (fast) alle statisch einkompiliert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

phpcli installieren

Postby becksbierbauch » 28. February 2008 09:44

habe das gleiche Problem und komme leider mit den o.g. Tipps nicht weiter.

der Fehler ist, dass auch bei mir folgende Meldung bei der Installation des OSTube Scriptes kommt:

Die Kommandozeilen Variante von PHP wurde nicht gefunden. Bitte stellen Sie sicher das php-cli installiert ist, und das mysql.so in der entsprechenden php.ini aktiviert wurde.

daraufhin habe ich in der php.ini folgende Zeile zugefügt:

extension=mysql.so

was nun beim Starten des Xampp zu folgender Fehlermeldung führt:

Starting XAMPP for Linux 1.6.4...
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/ex tensions/no-debug-non-zts-20060613/mysql.so' - /opt/lampp/lib/php/extensions/no- debug-non-zts-20060613/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0

Kann mir bitte jemand noch einen Tipp geben zu diesem Problem ?
linux is like a wigwam. no windows, no gates and a apache inside
becksbierbauch
 
Posts: 19
Joined: 18. February 2004 19:35
Location: Florstadt

Postby Wiedmann » 28. February 2008 09:50

Kann mir bitte jemand noch einen Tipp geben zu diesem Problem ?

Da dein Script das CLI nicht automatisch findet, musst du ihm sagen, wo das CLI zu finden ist. Beim LAMPP ist das IMHO "/opt/lampp/bin/php".

(Wo/wie man dieses Script konfiguriert, kann ich dir nicht sagen.
--> Anleitung lesen oder Author fragen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

thx

Postby becksbierbauch » 28. February 2008 09:58

genau das wars, vielen dank für die schnelle Hilfe.
linux is like a wigwam. no windows, no gates and a apache inside
becksbierbauch
 
Posts: 19
Joined: 18. February 2004 19:35
Location: Florstadt

Postby haeche » 09. April 2008 11:31

ich lieb euch hir hir seit einsame spitze
haeche
 
Posts: 12
Joined: 06. April 2008 20:22


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest