Fehler beim Verbindungsaufbau

Alles, was PHP betrifft, kann hier besprochen werden.

Postby Stefan » 03. April 2007 19:09

Grüß Gott,

na wie stehts mittlerweile?

ist Dir irgendwann aufgefallen das
{connect} Database Error: 1045 : Access denied for user 'ODBC'@'localhost' (using password: YES)

und
$host = "localhost"; // MySQL Hostname
$database = "test"; // MySQL Database
$db_username = "root"; // MySQL Username
$db_pass = ""; // MySQL Password
$db_port = ""; // Port der Datenbank - kann leer gelassen werden, default 3306

irgendwie nicht zusammen passt?
Lass doch mal wissen wie es sich in der Folge zugetragen hat.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby Dreknor » 03. April 2007 19:57

Hat bis jetzt leider nix geholfen.

Habs mit verschiedenen Nutzern probiert, da heißt die Meldung dann entsprechen ...@localhost aber Verbindung bekomme ich trotzdem keine :-(
Dreknor
 
Posts: 9
Joined: 28. March 2007 05:59

Postby Stefan » 03. April 2007 20:20

Gibs ja nicht....

Was passiert den, wenn Du das nette Beispiel von hier http://php.net/mysql_connect in einer NEUEN/LEEREN Datei ausprobierts?
Code: Select all
<?php
$link = mysql_connect('localhost', 'root', '');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>


Was die Nutzerdaten angeht, könntest Du ja einen Blick in die config.inc.php des phpMyAdmin werfen.

Egal, wenn das funktioniert, dürfte der Fehler wohl sonstwo in Deinem Projekt stecken.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Previous

Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests