fopen funktioniert nicht mehr

Alles, was PHP betrifft, kann hier besprochen werden.

fopen funktioniert nicht mehr

Postby juergen » 10. September 2003 16:16

Hallo!

An was kann es liegen das fopen(Url) nicht mehr funktioniert. Auch interne Links funktionieren nicht mehr.

Wir haben einen eigenen Server bei einem Provider stehen. Die Firewall ist angeblich laut Auskunft vom Provider offen.

PHP 4.3.2
allow_url_fopen = ON
safe mode = off
open_basedir = "Pfad zum Webpaket"

Was für Einstellung müssen noch auf dem Server gegeben sein das diese Funktioniert?

Wo und Wie kann ich die einzelnen Einstellungen überprüfen und richtigstellen.
_________________
mfg
Jürgen B.
mfg
Jürgen B.
juergen
 
Posts: 2
Joined: 10. September 2003 16:13

Postby Benzman » 10. September 2003 16:43

Mit diesen Einstellungen müsste es eigentlich funktionieren. Was kommt denn für ein Fehler wenn du fopen() benutzt?
User avatar
Benzman
 
Posts: 132
Joined: 27. July 2003 18:46
Location: Bayern

Postby juergen » 10. September 2003 16:53

Ich glaub das hier irgend etwas auf dem Server nicht mehr stimmt.

Betriebsystem: Debian

Das Script für den Test:
#Tragen sie hier den vollständigen Pfad zu ihrer Index DAtei ein.
$pfad="http://www.webedition.de/index.php";
$handle = fopen ($pfad, "r");
while (!feof($handle)) {
$buffer = fgets($handle, 10000);
echo $buffer;
}


Fehlermeldung:
Warning: fopen(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution (is your IPV6 configuration correct? If this error happens all the time, try reconfiguring PHP using --disable-ipv6 option to configure) in /xxx/html/webEdition/we/tmp/32d2d8622f268d7d23e6ef49593083b2 on line 33

Warning: fopen(http://www.webedition.de/index.php): failed to open stream: Resource temporarily unavailable in /xxx/html/webEdition/we/tmp/32d2d8622f268d7d23e6ef49593083b2 on line 33

Warning: feof(): supplied argument is not a valid stream resource in /xxx/html/webEdition/we/tmp/32d2d8622f268d7d23e6ef49593083b2 on line 34

Warning: fgets(): supplied argument is not a valid stream resource in /xxx/html/webEdition/we/tmp/32d2d8622f268d7d23e6ef49593083b2 on line 35
mfg
Jürgen B.
juergen
 
Posts: 2
Joined: 10. September 2003 16:13

Postby Benzman » 11. September 2003 10:25

Also die 1. Fehlermeldung besagt, dass anscheinend www.webedition.de nicht aufgelöst werden kann. Was das aber mit IPv6 zu tun hat weiß ich nicht. Ich tippe einfach mal darauf, dass der DNS Server nicht richtig konfiguriert ist.

Die anderen Fehler resultieren nur aus dem 1., sind also bedeutungslos.
User avatar
Benzman
 
Posts: 132
Joined: 27. July 2003 18:46
Location: Bayern


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests