php5.2

Alles, was PHP betrifft, kann hier besprochen werden.

php5.2

Postby asimov » 20. December 2006 15:02

Hallo, ich hab ihr ein Problem bei der Neuinstallation von PHP 5.2 auf meinem Apache Webserver. Die php5.dll die ich mir runtergeladen habe funzt nicht mit dem Server. Wo bekommt man eine Version her die funktioniert?
asimov
 
Posts: 9
Joined: 20. December 2006 03:48

Postby KingCrunch » 20. December 2006 16:23

Ma abgesehen davon, dass "funzt" ein echt hässliches Wort ist: Was funktioniert denn nicht bzw wie macht sich das bemerkbar?
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby deepsurfer » 20. December 2006 17:21

Wie schon im anderen Thread wäre es wichtig zu wissen
- Welche PHP5 Version du da installiert hast

und wie KingCrunch hier abermals verdeutlicht, wäre eine Fehlermeldung die du auf dem Bildschirm siehst angebracht diese hier zu schreiben.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby asimov » 20. December 2006 17:22

Ja hatte schnell und im Dialekt geschrieben Entschuldigung.
Der Apache lässt sich, seit ich php installiert habe nicht mehr starten. Interessanter weise kann ich aber die phpinfo.php die ich im htdocs verzeichnis habe problemlos aufrufen.
asimov
 
Posts: 9
Joined: 20. December 2006 03:48

Postby Wiedmann » 20. December 2006 17:38

Wenn der Apache nicht läuft, lässt sich auch keine PHP- (oder sonstige) Datei von diesem aufrufen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby asimov » 20. December 2006 17:43

Es gibt ja keine Fehlermeldung auf dem Bildschirm!
Nur der localhost bleibt blank und aufrufe von indexdateien werden ignoriert.
Die Versionsnummer 5.2.0
Und warum kann ich mir die phpinfo.php ansehen jede andere php Datei nicht?
asimov
 
Posts: 9
Joined: 20. December 2006 03:48

Postby KingCrunch » 22. December 2006 16:11

Es gibt ja keine Fehlermeldung auf dem Bildschirm!
Entweder das ist falsch (beachte auch die Serverlogs, etc) oder aber es funktioniert (vom Apachen aus) ^^
Nur der localhost bleibt blank[...]
Ahja, also auch kein Timeout? Dann läuft da irgendein Server ^^
[...]und aufrufe von indexdateien werden ignoriert.
Und wie macht sich das bemerkbar? Fehlermeldung? Index? 404?
Und warum kann ich mir die phpinfo.php ansehen jede andere php Datei nicht?
Und wie macht sich das bemerkbar? ;)

Also um mich ma zusammen zu fassen: Solange kein Timeout oder sowas auftritt, läuft da irgendein Server (nachprüfbar zB mit dem Portcheck von Xampp oder mit netstat). Fehler 404 oder vergleichbares deuten da eher auf etwas anderes hin. Zumal du die phpinfo ausgeben kannst, was ohne des laufenden Systems unmöglich ist.

Im Fall 2 (wonach es grad mehr klingt): Wo liegen deine PHPs und wie rufst du sie auf?
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests