Die Erweiterung mysql kann nicht geladen werden

Alles, was PHP betrifft, kann hier besprochen werden.

Die Erweiterung mysql kann nicht geladen werden

Postby Thomas Mc Kie » 09. November 2006 20:26

Hallo,

ich suche schon seit Stunden eine Lösung für das Problem, Threads dazu gibt es ja genug, aber die darin enthaltenen Lösungen funzen bei mir nicht :-(

Apache2.2.3 installiert und funktioniert
PHP 5.2.0 installiert und funktioniert (zumindest ein kleines Testscript)
MySQL 5.0.27 installiert und funktioniert (per Eingabeaufforderung, also mysqld mysql mysqladmin usw.)
phpmyadmin 2.9.1

httpd.conf (Auszug):
DocumentRoot "C:/Localhost/Apache2.2/htdocs"
PHPIniDir "C:/Localhost/PHP/"
LoadModule php5_module "C:/Localhost/PHP/php5apache2_2.dll"
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
SetEnv PHPRC C:/Localhost/PHP (<-- war ein Lösungsvorschlag bei meiner Suche, hatte das aber auch ohne diesen Befehl und ging leider auch nicht)


php.ini (Auszug)
doc_root = "C:\Localhost\Apache2.2\htdocs\"
user_dir =
upload_tmp_dir="F:\DOKUME~1\MCKIE-~1\LOKALE~1\Temp\php\session"
session.save_path="F:\DOKUME~1\MCKIE-~1\LOKALE~1\Temp\php\upload"
extension_dir = "C:\Localhost\PHP\ext\"
extension=php_mysql.dll
[MySQL]
...
mysql.default_port = 3306
mysql.default_socket =
mysql.default_host = "localhost"
mysql.default_user = "root"
mysql.default_password =


my.ini (Auszug):
[client]

port=3306
[mysql]
default-character-set=latin1
[mysqld]
port=3306
basedir="C:/Localhost/MySQL Server 5.0/"
datadir="C:/Localhost/MySQL Server 5.0/Data/"
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"


confic.inc.php (komplett)
<?php
$cfg['blowfish_secret'] = 'laberrababer0815'; // use here a value of your choice

/* Authentication type */
$i=0;
$i++;

/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = '***********';

/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';

?>

Auch in sämtliche vorgeschlagenen Verzeichnisse habe ich die Dateien libmysql.dll sowie php_mysql.dll zusätzlich kopiert, ohne Erfolg (also ins Systemverzeichnis, auch in System32, natürlich im root der php-Installation, im bin von apache)

Ich habe die php.ini nur 1 mal auf dem PC
my.ini einmal im Systemverzeichniss, und auch einmal im root der MySql-Installation, beide identisch.

noch kurz Path:
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Localhost\PHP\;C:\Localhost\MySQL Server 5.0\bin\


Ich bin ziemlich ratlos und hoffe mir kann wer noch einen guten Rat geben, wie ich das zum Laufen bringe, wo der Fehler liegt.

xampp hatte ich auch schon mal installiert, aber so richtig hinbekommen hatte ich es nicht, außerdem wollte ich mich an ein paar Büchern, die ich habe, entlanghangeln können.

mfg

Thomas Mc Kie
Thomas Mc Kie
 
Posts: 1
Joined: 09. November 2006 19:52

Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests