Mailserver Mercury + PHP

Alles, was PHP betrifft, kann hier besprochen werden.

Mailserver Mercury + PHP

Postby deady » 20. October 2006 14:21

hi leute... ich habe probleme mit dem mercury mailserver der xampp mitlliefert.

das xampp paket ist auf einem xp rechner mit ip adresse 10.134.1.87. der dns server hat einen eintrag der mit der adresse im intranet auf ccb.bit.admin.ch zeigt. also ccb.bit.admin.ch zeigt auf 10.134.1.87 :)

jetzt habe ich die mail konten erstellt und der server läuft. auch mails kann ich vom mercury aus verschicken. dies leider nur an mercury postfächer, aber immerhin das. den rest habe ich nicht zum laufen gebracht.

jetzt habe ich einen php script gemacht mit einfach mailfunktion

Code: Select all
<?
$empfaenger = "manuel_mueller@ccb.bit.admin.ch";
$absender = "postmaster@ccb.bit.admin.ch";
$text = "irgendein text";
$betreff = "der super betreff";
mail($empfaenger,$betreff,$text,$absender) or die ("schiefgelaufen");
?>


in der php.ini steht das:

Code: Select all
mail function]
; For Win32 only.
SMTP = 10.134.1.87
smtp_port = 25

; For Win32 only.
sendmail_from = postmaster@10.134.1.87

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path = "C:\xampp\xampp\sendmail\sendmail.exe -t"

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =


der browser gibt mir das aus:


Warning: mail() [function.mail]: Failed to connect to mailserver at "10.134.1.87" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\xampp\htdocs\test\mail.php on line 6
schiefgelaufen

warum??? :shock:

liebe grüsse

deady
deady
 
Posts: 1
Joined: 20. October 2006 13:58

Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests