Error parsing php.ini

Alles, was PHP betrifft, kann hier besprochen werden.

Error parsing php.ini

Postby widmerr » 22. August 2006 11:50

Ich habe auf meinem PC Apache 2.2, PHP5 und MySQL 5 installiert.

Als Installations- und Konfigurationsanleitung habe ich den WinTotal Artikel
"Einrichten einer lokalen Testumgebung – Apache, PHP & Mysql" verwendet:
http://www.wintotal.de/Artikel/lokalete ... gebung.php

Problem:
Beim starten des PC erhalte ich die zweimal eine Fehlermeldung. Die Fehlermeldung lässt sich reproduzieren, wenn der Dienst Apache 2.2 neu gestartet wird.

Fehlermeldung:

Error parsing E:\Webserver\php5\php.ini online 640

online 640 verweist auf den folgenden Eintrag:

639 #
640 LoadModule php5_module "e:/Webserver/php5/php5apache2.dll"
641 AddType application/x-httpd-php .php
642 PHPIniDir "e:/Webserver/php5"
643 #

Die php5apache2.dll ist im angegebenen Verzeichnis vorhanden.


Zur Information gebe ich die Systeminformation wieder, wie sie von php.info zurückgegeben wird.

Ich hoffe, es kann mir jemand weiterhelfen bei der Fehler- und Lösungssuche.

Mit freundlichen Grüssen

Rudolf Widmer

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

System Windows NT VENUS 5.1 build 2600
Build Date May 4 2006 10:30:29
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
Server API Apache 2.2 Handler www.apachelounge.com
Virtual Directory Support enabled
Configuration File (php.ini) Path E:\Webserver\php5\php.ini
PHP API 20041225
PHP Extension 20050922
Zend Extension 220051025
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, http, ftp, compress.zlib, compress.bzip2
Registered Stream Socket Transports tcp, udp
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*, bzip2.*
widmerr
 
Posts: 6
Joined: 22. August 2006 06:21

Postby kleinweby » 22. August 2006 12:25

moin,

hast du mal den roten Hinweis auf der Seite gelesen?
!! HINWEIS !!

Wie sich gezeigt hat, gibt es Probleme mit der Kombination Apache 2.2.x und PHP 5.1.x.

Dieses Tutorial beschreibt die Installation von Apache 2.0.x und PHP 5.0.x.
Wer nicht unbedingt auf den neuesten Apache angewiesen ist, sollte vorerst bei der Version 2.0.x bleiben.


Die beschreiben da die anleitung für apache 2.0.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Apache und PHP arbeiten zusammen

Postby widmerr » 23. August 2006 06:38

Danke für den Hinweis!

Apache 2.0.59 PHP 5.03 spielen zusammen, Apache 2.0.59 und PHP 5.1.4 nicht.

Rudolf Widmer, DAU (Dümmster anzunehmender User!)
widmerr
 
Posts: 6
Joined: 22. August 2006 06:21


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest