Installation Apache 2.2 und PHP

Alles, was PHP betrifft, kann hier besprochen werden.

Installation Apache 2.2 und PHP

Postby jokobe » 28. July 2006 12:14

Ich habe auf zunächst Apache 2.2 installatiert und danach PHP 5.
Wenn ich jetzt das PHP Modul in http.conf einbinde:

LoadModule php5_module "C:/php/php5apache2.dll"
AddType application/x-httpd-php .php

lässt sich Apache nicht mehr starten
("The requested operation has failed")

Hat jemand einen Tip zu diesem Problem???

jokobe
jokobe
 
Posts: 1
Joined: 28. July 2006 11:43
Location: Wolfenbüttel

Postby Wiedmann » 28. July 2006 14:14

Ich habe auf zunächst Apache 2.2 installatiert und danach PHP 5.
Wenn ich jetzt das PHP Modul in http.conf einbinde:

Welches PHP5?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Togbuh » 02. August 2006 21:13

Too early...
Togbuh
 
Posts: 1
Joined: 02. August 2006 20:53
Location: USA

Postby Susi111 » 03. August 2006 14:55

habe dasselbe problem:

The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 115 of C:/Programme/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/php/php5apache2.dll into server: Das angegebene Modul wurde nicht gefunden.

Zeile 115:
LoadModule php5_module "C:\php\php5apache2.dll"
Susi111
 
Posts: 4
Joined: 03. August 2006 14:31

Postby Wiedmann » 03. August 2006 15:02

Cannot load C:/php/php5apache2.dll into server

Du hast ein Modul für den Apache 2.0.x

httpd.exe: Syntax error on line 115 of C:/Programme/Apache Software Foundation/Apache2.2/conf/httpd.conf:

Hast aber einen Apachen 2.2.x

Oder bist du sicher, dass dieses Modul für deine Apache-Version ist?

BTW:
Die "php5ts.dll" muss vom Apache auch noch gefunden werden können.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Susi111 » 03. August 2006 15:43

aber das müsste ja trotzdem funktionieren, oder nicht?
das gibt es ja gar nicht für apache 2.2. hab ich jedenfalls nichts gefunden.
ich hab auch keinen syntax fehler
Susi111
 
Posts: 4
Joined: 03. August 2006 14:31

Postby Wiedmann » 03. August 2006 15:49

aber das müsste ja trotzdem funktionieren, oder nicht?

Wen das Modul für den Apache 2.0 ist, funktioniert es nicht mit dem Apache 2.2. Punkt.

hab ich jedenfalls nichts gefunden

Das ist eher wahrscheinlich ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Susi111 » 03. August 2006 15:52

und woher bekomme ich das?
Susi111
 
Posts: 4
Joined: 03. August 2006 14:31

Postby legolas13 » 08. September 2006 18:09

hier: http://www.gknw.at/development/apache/httpd-2.2/win32/modules/
Ich hatte das gleiche Problem, und mit diesem Module klappt's

:D
legolas13
legolas13
 
Posts: 1
Joined: 08. September 2006 17:50

Postby Susi111 » 08. September 2006 19:01

ich habe jetzt apache 1.3 mit php5 installiert, aber trotzdem Danke.
Liebe Grüße
Susi
Susi111
 
Posts: 4
Joined: 03. August 2006 14:31

Postby Bushranger » 11. September 2006 15:36

wie kann ich das error_reporting einbindenum mir die evt. fehler anzeigen zu lassen?
Bushranger
 
Posts: 102
Joined: 15. April 2005 17:35
Location: Niedersachsen


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests