PHP.ini

Alles, was PHP betrifft, kann hier besprochen werden.

PHP.ini

Postby Encrier » 15. July 2006 06:05

Hello,

I have installed on my computer;

# Apache 2.2.2
# MySQL 5.0.21
# PHP 5.1.4
osCommerce 2.2

When I try to go to;
http://localhost/encrier/admin/index.php

I get the following error.
Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

I have changed all the register_globals in the php.ini files I could find, but no results.
I deleted all the new installed software and their cookies an re-installed them and started all over again. No luck

Can I please get any support in this matter?

Thank you in advance and have a nice day,
Best regards
Paul Subelack
"There is no way to happiness, happiness is the way...."
Encrier
 
Posts: 23
Joined: 08. June 2006 05:43

Postby Wiedmann » 15. July 2006 11:19

I have changed all the register_globals in the php.ini files I could find, but no results.

Look in phpinfo() which is the right "php.ini".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Encrier » 16. July 2006 05:21

When I open phpinfo.php in c:\Program Files\xampp\phpMyAdmin, I see this;

<?php
/* $Id: phpinfo.php,v 2.5 2005/11/22 11:58:37 cybot_tm Exp $ */
// vim: expandtab sw=4 ts=4 sts=4:


/**
* Gets core libraries and defines some variables
*/
define( 'PMA_MINIMUM_COMMON', true );
require_once('./libraries/common.lib.php');


/**
* Displays PHP information
*/
if ( $GLOBALS['cfg']['ShowPhpInfo'] ) {
phpinfo();
}
?>

The other phpinfo file I foudn at c:\Program Files\xampp\htdocs\xampp
says;

<?php
phpinfo();
?>

The funny thing is, that the files opens straight away in "Wordpad" at doubleclick.....

I hope this will help.

Best regards,
Paul
"There is no way to happiness, happiness is the way...."
Encrier
 
Posts: 23
Joined: 08. June 2006 05:43

Postby Wiedmann » 16. July 2006 12:27

The funny thing is, that the files opens straight away in "Wordpad" at doubleclick.....

You must load a PHP file with "http://..." in a webbrowser and not with a doubleclick in explorer.

BTW:
There is a link in the menu from the XAMPP demopages.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby dmd2 » 01. August 2006 05:39

To change configurations in the correct php.ini, you must find this file in:

Code: Select all
 ... \xampp\apache\bin\php.ini


After this, you must restart apache to changes work.

The funny thing is, that the files opens straight away in "Wordpad" at doubleclick.....


You can modify this by clicking on the file with yhe right button and click on "open with" and "choose program" and change to your prefered software.
Or you can do this in windows explorer or explorer clicking on menu "tools" and "folder options" and go to tab "file types" and change the file association.

Ps.: maybe this ways to change the file association are incorrect because my windows is in portuguese.

I hope this work
Image
dmd2
 
Posts: 5
Joined: 21. July 2006 21:50

Postby Encrier » 01. August 2006 05:49

Thank you for your reply, I already found it.
Have a nice day
"There is no way to happiness, happiness is the way...."
Encrier
 
Posts: 23
Joined: 08. June 2006 05:43


Return to PHP

Who is online

Users browsing this forum: No registered users and 3 guests