PHP 5.1.4 mit Apache 2.2.2

Alles, was PHP betrifft, kann hier besprochen werden.

PHP 5.1.4 mit Apache 2.2.2

Postby keflwftj » 08. May 2006 21:01

...
Last edited by keflwftj on 05. June 2007 15:45, edited 1 time in total.
keflwftj
 
Posts: 8
Joined: 12. February 2005 14:23

Postby keflwftj » 09. May 2006 14:35

...
Last edited by keflwftj on 05. June 2007 15:45, edited 1 time in total.
keflwftj
 
Posts: 8
Joined: 12. February 2005 14:23

Postby Zaeggu » 09. May 2006 21:15

Hol dir die neueste Beta2 vom Xampp, dann haste dies alles drinnen!
Gruss Zaeggu
Zaeggu
 
Posts: 37
Joined: 20. April 2006 08:00

Postby powl » 18. May 2006 14:58

es muss doch aber für das problem ne lösung geben? würde das gerne ohne xampp betreiben :?
powl
 
Posts: 5
Joined: 18. May 2006 14:55

Postby Bushranger » 18. May 2006 17:36

hallo,

es müßte so gehen
PHP and Apache 2.0 as CGI

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php

# For PHP 5
Action application/x-httpd-php "/php/php-cgi.exe"

ich hab allerdings die binary form genommen und es dann auch zum laufen bekommen mit
PHP and Apache 2.0 als Module

# For PHP 5 do something like this:
LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"

probier mal aus ob es klappt, aus
http://www.php-homepage.de/manual/insta ... pache2.php
Bushranger
 
Posts: 102
Joined: 15. April 2005 17:35
Location: Niedersachsen

Postby powl » 18. May 2006 18:10

thx,

Forbidden

You don't have permission to access /php/php-cgi.exe/powl.php on this server.

irgendwer ne Idee? :o
powl
 
Posts: 5
Joined: 18. May 2006 14:55

Postby powl » 18. May 2006 19:08

keiner ne idee? :O
powl
 
Posts: 5
Joined: 18. May 2006 14:55

Postby Bushranger » 20. May 2006 09:09

klappt es mit den Modulen nach einbinden der Zeilen auch nicht?
Bushranger
 
Posts: 102
Joined: 15. April 2005 17:35
Location: Niedersachsen

Postby james007 » 16. June 2006 17:46

Thomas Belser wrote:Kann keiner helfen? Irgendwie muss es doch möglich sein, PHP 5.1.4 unter Apache 2.2.2 zum Laufen zu bringen. :(


Wer bei der Installation von PHP5 in Apache V2.2.x

den Fehler "Permission denied" bekommt, wenn er PHP Scripte ausführen will, muss
die Restriktionen in der httpd.conf etwas lockern.

Man suche und kommentiere folgende Bereiche aus:

<Directory />
Options FollowSymLinks
AllowOverride All
# AllowOverride None
# Order deny,allow
# Deny from all
# Satisfy all
</Directory>

Dann klappt es !

Ich habe AllowOverride ALL genommen damit ich auch htaccess nutzen kann. Ist also optional.

Habe auch lange gesucht und es eben erst herrausgefunden.

Man hat wohl bei der V2.2.x die Restriktionen etwas zu eng geschnürt.
james007
 
Posts: 16
Joined: 16. June 2006 17:38

Postby Aoni-Maan » 21. June 2006 23:49

Hallo,

bei mir ist das so:

Sobald ich

Code: Select all
PHPIniDir "C:/Programme/PHP"


bzw.

Code: Select all
LoadModule php5_module "C:/Programme/PHP/php5apache2.dll"


(PHP liegt also bei mir im Verzeichnis C:\Programme\PHP\)

in die httpd.config-Dati einfüge, läßt sich Apache (2.2.2) nicht neustarten. Die Frage ist nun: Warum?

Ich habe mich bei der Installation an folge Anleitung gehalten:
http://www.brain-and-trust.de/index.php?ID1=121

@James007
Hab auch Deine Option probiert, scheint aber nichts zu ändern.

Wär nett, wenn jemand helfen kann.
Aoni-Maan
 
Posts: 1
Joined: 21. June 2006 23:36

Postby Wiedmann » 22. June 2006 00:05

in die httpd.config-Dati einfüge, läßt sich Apache (2.2.2) nicht neustarten. Die Frage ist nun: Warum?

Frag den Apache, der sagt dir ja was ihn stört wenn er nicht starten kann.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Wiedmann » 22. June 2006 00:19

Noch ein Nachtrag und weil mich das jetzt mal selbst interessiert hat:
Wie es auch schon im PHP-Manual steht, ist die "php5apache2.dll" für den Apache 2.0.x und nicht für den Apache 2.2.x (für diesen wird kein Modul mitgeliefert).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby james007 » 22. June 2006 03:35

Wiedmann wrote:Noch ein Nachtrag und weil mich das jetzt mal selbst interessiert hat:
Wie es auch schon im PHP-Manual steht, ist die "php5apache2.dll" für den Apache 2.0.x und nicht für den Apache 2.2.x (für diesen wird kein Modul mitgeliefert).


Ich beziehe meine PHP Versionen immer als ZIP von www.php.net
und die Version geht für Apache 2.0.x wie auch für Apache 2.2.x.

Um genau herrauszufinden warum der Apache nicht startet muss man den Apache von der Konsole aus starten und die Fehlermeldung lesen.

Bei Apache 2.2.x <instpfad>/bin/httpd.exe
Bei Apache 2.0.x <instpfad>/bin/apache.exe

PS: Dieser Thrad bezog sich auf die Meldung bei der Ausführung von Apache mit "You dont have permissins to .."

Dieser Fehler scheint mir anders gelagert zu sein.
james007
 
Posts: 16
Joined: 16. June 2006 17:38

Postby Wiedmann » 22. June 2006 04:55

Ich beziehe meine PHP Versionen immer als ZIP von www.php.net
und die Version geht für Apache 2.0.x wie auch für Apache 2.2.x.

Du solltest genauer lesen ;-)
Wiedmann wrote:und nicht für den Apache 2.2.x (für diesen wird kein Modul mitgeliefert).

Meine Antwort war ja für "Aoni-Maan", der PHP als Modul in den Apache integrieren will/wollte.

Das CGI kannst du natürlich bei jeder Apache-Version benutzen oder überhaupt bei jedem Webserver der die CGI-Schnittstelle unterstützt. (Du bist leider nur über einen der wenigen Fehler/Ungenauigkeit im PHP-Manual gestolpert)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby james007 » 22. June 2006 21:28

Wiedmann wrote:Du solltest genauer lesen ;-)
Meine Antwort war ja für "Aoni-Maan", der PHP als Modul in den Apache integrieren will/wollte.

Das CGI kannst du natürlich bei jeder Apache-Version benutzen oder überhaupt bei jedem Webserver der die CGI-Schnittstelle unterstützt. (Du bist leider nur über einen der wenigen Fehler/Ungenauigkeit im PHP-Manual gestolpert)

Boing.

Natuerlich hast du Recht.
Asche über mein Haupt ;-)

In der PHP5 Install.txt steht es ja auch drin.

* sapi/php4apache.dll (php5apache.dll) - Apache 1.3.x module.
* sapi/php4apache2.dll (php5apache2.dll) - Apache 2.0.x module.
james007
 
Posts: 16
Joined: 16. June 2006 17:38

Next

Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests