php-switch von 5 auf 4 geht nicht

Alles, was PHP betrifft, kann hier besprochen werden.

php-switch von 5 auf 4 geht nicht

Postby Samson2 » 20. January 2006 12:25

Nach der Umschaltung von 5 auf 4 (Batchdatei meldet keine Fehler) ploppen nach xampp_start.exe mehrere Fensterchen auf:

Warning: Unknown(): Unable to load dynamic library 'd:\XAMPP\xampp\php\extensions\php_mbstring.dll' - Ein an das System angeschlossenes Gerät funktioniert nicht.

Warning: Unknown(): Unable to load dynamic library 'd:\XAMPP\xampp\php\extensions\php_exif.dll' - Ein der für die Ausführung dieser Anwendung notwendige Bibliothekdateien kann nicht gefunden werden.

Warning: ZendOptimizer for PHP 4.3.x cannot be found (expected at 'd:\XAMPP\xampp\php\zendOptimizer\php-4.3.x\ZendOptimizer.dll') - try reinstalling Zend Optimizer

Das vierte Popup wird dann nicht mehr angezeigt.
Das Laden der Seite localhost/xampp oder eines anderen PHP-Skriptes schlägt fehl. Der Fortschrittsbalken vom Browser hängt, die Eieruhr ist zu sehen, nichts passiert.

Unter PHP5 habe ich keine Probleme. Ich benötige aber Version 4.

Ein manuell konfiguriertes Paket mit PHP 4.x und Apache 1.3.26 funktioniert einwandfrei. Allerdings kann ich das Paket nicht nutzen, ohne vorher Xampp gekillt zu haben, insbesondere den Apache2-Dienst.

Betriebssystem Win98
Samson2
 
Posts: 3
Joined: 20. January 2006 10:42

Dasselbe in Grün

Postby walber2409 » 26. January 2006 22:12

Ich habe exakt dasselbe Problem: WIN 2000 / SP4; aktuelle XAMPP-Version.

Werner.

8)
MfG und vielen Dank im voraus!

walbo
walber2409
 
Posts: 29
Joined: 15. June 2004 07:20
Location: Nürnberg

Postby Wiedmann » 27. January 2006 01:40

walber2409 wrote:Ich habe exakt dasselbe Problem: aktuelle XAMPP-Version.

Mit exakt den selben Fehlermeldungen?

Samson2 wrote:Warning: ZendOptimizer for PHP 4.3.x cannot be found (expected at 'd:\XAMPP\xampp\php\zendOptimizer\php-4.3.x\ZendOptimizer.dll') - try reinstalling Zend Optimizer

Da der hier was von PHP 4.3.x schreibt, um welchen XAMPP geht's denn da? Ist ja schon eine Weile PHP4.4.x aktuell.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Samson2 » 27. January 2006 08:53

Die Version, die am 20.1.06 aktuell war. Das müßte 1.5.1 gewesen sein.
Samson2
 
Posts: 3
Joined: 20. January 2006 10:42

Postby Wiedmann » 27. January 2006 13:08

Die Version, die am 20.1.06 aktuell war. Das müßte 1.5.1 gewesen sein.

Also bei der Fehlermeldung kaum möglich. Zumindest bei einer Neuinstallation (es gab ja kein Upgrade). Erzähl doch mal von der Vorgeschichte deines XAMPP's?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest