safe mode off für v-host

Alles, was PHP betrifft, kann hier besprochen werden.

safe mode off für v-host

Postby skiordie » 17. December 2005 19:35

Hi,

ich möchte auf einem v-host den safe mode off stellen. Dazu habe ich in den V-Host

php_admin_flag safe_mode off

eingetragen. Jedoch wird mit php_info() immernoch safe_mode als on angezeigt. Jetzt habe ich für alle v-hosts

php_admin_flag safe_mode on

eingestellt und in der php.ini diesen auf off gestellt. Jetzt ist er überall off. Gibt es dafür vielleicht noch irgendeine Einstellung die man vorher vornehmen sollte? Oder gibt es noch andere Möglichkeiten?

Vielen Dank,
Tom
skiordie
 
Posts: 5
Joined: 17. December 2005 19:33

Postby skiordie » 20. December 2005 11:00

Kennt sich denn keiner damit aus?

Tom
skiordie
 
Posts: 5
Joined: 17. December 2005 19:33

Postby deepsurfer » 20. December 2005 11:55

mal vorsichtig gegenfrag, ;)
hast du auch ein "neues" phpinfo im VHOST pfad geschrieben oder rufst du immer das vom Willkommenscreen auf ?

Desweiteren poste mal einen deiner VHOST mal hierein (IP / Domäme kannst du ja austauschen)
Ich vermute das du den Eintrag php_admin_value safe_mode On nicht in der Directory Anweisung eingebaut hast.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby skiordie » 20. December 2005 12:08

also ich hab das ganz einfach so reingeschrieben:

Code: Select all
<VirtualHost *:80>
php_admin_flag safe_mode on
ServerName...
...
</VirtualHost>

steht so im Buch Dedizierte Webserver einrichten und administrieren von Michael Hilscher!
skiordie
 
Posts: 5
Joined: 17. December 2005 19:33

Postby deepsurfer » 20. December 2005 13:17

skiordie wrote:also ich hab das ganz einfach so reingeschrieben:

Code: Select all
<VirtualHost *:80>
php_admin_flag safe_mode on
ServerName...
...
</VirtualHost>

steht so im Buch Dedizierte Webserver einrichten und administrieren von Michael Hilscher!


Dein VHOST (schade das du den nicht komplett gepostest hast :shock: ) könnte dann so aussehen.

Code: Select all
<VirtualHost *:80>
 ServerName testserver.de
 DocumentRoot c:\mein\pfad\zum\webverzeichnis
 ServerAdmin meine@mailadresse.biz
  <Directory "c:\mein\pfad\zum\webverzeichnis">
   php_admin_value safe_mode On
   AllowOverride All
   Options Indexes FollowSymLinks
   Order allow,deny
   Allow from all
  </Directory>
</VirtualHost>
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby skiordie » 20. December 2005 13:40

hab deine Änderungen mal vorgenommen...hier der komplette v-host(!!!):

Code: Select all
<VirtualHost *:80>
#:/usr/local/lib/php
DocumentRoot /home/myweb/public_html/
ServerName www.test.de
IndexOptions
DirectoryIndex index.htm index.html index.shtml start.htm start.html start.shtml index.php index.php3
<Directory "/home/myweb/public_html/">
php_admin_value open_basedir /home/myweb/public_html/
php_admin_value upload_tmp_dir /home/myweb/public_html/tmp
php_admin_flag safe_mode off
AllowOverride All
Order allow,deny
Allow from all
</Directory>
CustomLog "|/usr/local/visas/cronolog/cronolog --symlink=/usr/local/visas/logfiles/myweb/access_log --prev-symlink=/usr/local/visas/logfiles/myweb/current_access_log /usr/local/visas/logfiles/myweb/%Y/%m/%d/access_log" combined
SuexecUserGroup cry24de www
ScriptAlias /cgi-bin/ /home/myweb/public_html/cgi-bin/
</VirtualHost>


Safe Mode ist immernoch an...Hab eine Installation von Gallery2 laufen und die zeigt mir das an...
skiordie
 
Posts: 5
Joined: 17. December 2005 19:33

Postby deepsurfer » 20. December 2005 13:53

auf was ist deine global_register in der php.ini gestellt ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby skiordie » 20. December 2005 14:01

meinst du

register_globals


dieser wert ist off.

Tom
skiordie
 
Posts: 5
Joined: 17. December 2005 19:33


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests