php login auf mysql nur mittels phpmyadmin nicht per php!

Alles, was PHP betrifft, kann hier besprochen werden.

php login auf mysql nur mittels phpmyadmin nicht per php!

Postby tntkane » 09. December 2005 19:44

Hallo,
rasch zu meinem Problem:
Habe die akt. XAMMP Version für Windows installiert!
1. Habe
Code: Select all
c:\Programme\xampp\mysql\bin\mysqladmin -u root password meinPasswort

ausgeführt.
2. Habe config.inc.php im phpmyadmin geändert (config)
3. Habe mich mit Browser eingeloggt auf phpmyadmin und es klappte wunderbar.
4. Habe ich diese phpdatei aus dem Browser aufgerufen (http://server/test.php):
Code: Select all
<?php

require("zugangsdaten.php");

    //Verbindung zur Datenbank herstellen:
$db = @MYSQL_CONNECT($db_server,$db_user,$db_password);
$db_select = @MYSQL_SELECT_DB($db_name);

    $name = "admin";
    $pass = "daspw";
    $userid = -1;
    $sql="SELECT UserId
    FROM users
    WHERE UserName='".$name."' AND UserPass=MD5('".$pass."')
    LIMIT 1";
    $result=mysql_query($sql);
    if (mysql_num_rows($result)==1)
    {         $user=mysql_fetch_assoc($result);
       echo $user['UserId'];
      if ($userid >= 0)
      {
         echo "Eingeloggt!";
      }
      else
      {
         echo "Hello!";
      }

        return $user['UserId'];
    }
    else
        return false;

?>

mit dieser zugangsdaten.php
Code: Select all
<?php

/* Datenbankserver - In der Regel die IP */
$db_server = "192.168.0.79";
/* Datenbankname */
$db_name = "homepage";
/* Datenbankuser */
$db_user = "root";
/* Datenbankpasswort */
$db_password = "dasrootPW";

?>

Die Daten stimmen auch. Der Server läuft auch. Die Datenbank homepage mit der Tabelle users ist angelegt und enthält auch den nötigen Datensatz bereit. Das habe ich wiederum mit phpmyAdmin herausgefunden. Hier nun die Fehlermeldung:
Code: Select all

Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Programme\xampp\htdocs\phptest\test.php on line 18

Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in C:\Programme\xampp\htdocs\phptest\test.php on line 18

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in C:\Programme\xampp\htdocs\phptest\test.php on line 19

Ich hoffe das es einen solchen Beitrag noch nicht gibt. Habe auch danach gesucht und nix gefunden. Auch google spuckt Seiten aus die nicht exakt dieses Problem haben und daher die Lösungen nicht funktionieren die sie anbieten. Merkt man das ich verzweifelt bin?
^^
Bitte um Hilfe
tntkane
 
Posts: 1
Joined: 09. December 2005 19:01

Postby nattl » 11. December 2005 08:38

nimm mal die @ von den db-aufrufen weg und schau was du dann für eine fehlermeldung bekommst...
User avatar
nattl
 
Posts: 22
Joined: 26. October 2005 07:50
Location: Vienna


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest