anmeldungs-script funzt mit xampp aber nicht auf Server

Alles, was PHP betrifft, kann hier besprochen werden.

anmeldungs-script funzt mit xampp aber nicht auf Server

Postby cueneyt » 24. October 2005 10:37

Hallo alle zusammen,

habe eine anmeldung mit Benutzernamen,Passwort zu dem werden sessionvariablen definiert...kann mich wenn ich meine Seiten auf Server kopiere nicht anmelden...aber auf meinem Rechner mit xampp läuft alles wie geschmiert...kann mir jemand weiterhelfen..


Gruß Cueneyt
cueneyt
 
Posts: 6
Joined: 07. October 2005 09:34

Postby Wiedmann » 24. October 2005 11:24

Zu wenig Infos um zu helfen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Anmeldung funzt mit xampp aber nicht auf dem Server

Postby cueneyt » 24. October 2005 12:28

also mehr Info...

Habe eine Anmedung(Benutzername,Passwort) für geschützte seiten...diese funktioniert bei mir und anderen Rechnern ohne Probleme Xampp..wenn ich es aber aufs Server ziehe geht es nicht..

login.php

Code: Select all


<?php require_once('Connections/gruppe.php'); ?>
<?php
// Session starten
session_start ();

// Datenbankverbindung aufbauen
if (!mysql_select_db($database_gruppe, $gruppe))
{
  die ("Keine Verbindung zur Datenbank");
}

$sql = "SELECT ".
    "user_id, Benutzername, Name, Vorname ".
  "FROM ".
    "benutzer ".
  "WHERE ".
    "(Benutzername like '".$_REQUEST["name"]."') AND ".
    "(Passwort = '".$_REQUEST["pwd"]."')";
$result = mysql_query ($sql);

if (mysql_num_rows ($result) > 0)
{
  // Benutzerdaten in ein Array auslesen.
  $data = mysql_fetch_array ($result);

  // Sessionvariablen erstellen und registrieren
  $_SESSION["MM_user_Id"] = $data["user_id"];
  $_SESSION["user_nickname"] = $data["Benutzername"];
  $_SESSION["MM_Username"] = $data["Name"];
  $_SESSION["user_vorname"] = $data["Vorname"];

  header ("Location: uebersicht.php");
}
else
{
  header ("Location: Anmeldung.php?fehler=1");
}
?>



und zwar werde ich wenn ichs aufs server ziehe trotz der korrrekten Eingabe des Benutzernamens und Passworts auf die zugriffverweigert.htm verwiesen...dies passiert weil am Anfang der geschützten Seite kontolliert wird od die Session-Variablen gesetzt sind..wenn nicht dann gehts ab nach

zugrffverweigert.htm



Code: Select all

<?php
session_start ();
if (!isset ($_SESSION["MM_user_Id"]))
{
  header ("Location: zugriffverweigert.htm");
}
?>




auf dem Server ist die PHP ver.:4.3.11 drauf

ich verstehe nicht wie kann es sein das es bei mir läuft aber nicht auf dem Server...Die Cookies sind eingeschalltet und auch mit anderen Browsern ausprobiert..keine Chance...Brauche dringend Hilfe..


Gruß Cüneyt
cueneyt
 
Posts: 6
Joined: 07. October 2005 09:34

Postby jakimo72 » 24. October 2005 18:01

Vor dem Aufruf von session_start() und header()
darf kein Zeichen gesendet worden sein. Häufig
ist Windows da ein bischen großzügig, aber Linux sehr streng.

Also vor dem ersten "<?php" darf keine Leerzeile oder Leerzeichen sein,
und ich würde darauf achten, dass vor header() nur exakt
ein "<?php" steht.
User avatar
jakimo72
 
Posts: 151
Joined: 07. February 2005 13:25
Location: Hamburg-Barmbek


Return to PHP

Who is online

Users browsing this forum: No registered users and 3 guests