Problem mit dem versenden von Mails mit fsockopen

Alles, was PHP betrifft, kann hier besprochen werden.

Problem mit dem versenden von Mails mit fsockopen

Postby KaeseGewitter » 04. September 2005 15:19

Hi,

ich arbeite zur Zeit an einem Script, das mails mithilfe des PHPMailers versendet. PHPMailer versendet die E-Mail mithilfe einer Socket-Verbindung. Wenn ich dies über einen stink normalen Webserver lafuen lasse (kein lokaler) funktioniert das Script wunderbar. Wenn ich das Script allerdings über meinen lokalen Webserver (ein Xampp Packet) laufen lasse, wird die E-Mail nicht gesendet.

Weiß jemand, was ich machen muss, damit es funktioniert?

MFG

Klaus
KaeseGewitter
 
Posts: 5
Joined: 04. September 2005 15:08

Postby Wiedmann » 04. September 2005 15:22

Fehlermeldung?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KaeseGewitter » 04. September 2005 15:45

Der Server meint, dass er den Befehl nicht kennt, allerdings kann dies ja nicht sein, da die Befehle ja auf dem anderen Webserver klappen. Sprich es muss am Xampp Packet liegen.
KaeseGewitter
 
Posts: 5
Joined: 04. September 2005 15:08

Postby Wiedmann » 04. September 2005 16:00

Der Server meint, dass er den Befehl nicht kennt,

Und welchen?

BTW:
Der Server (Apache) kennt einen "Befehl" nicht, oder PHP?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KaeseGewitter » 04. September 2005 16:09

der SMTP Server, auf dem ich mit fsockopen connecte.
KaeseGewitter
 
Posts: 5
Joined: 04. September 2005 15:08

Postby Wiedmann » 04. September 2005 16:17

:?:

Lese die Frage bitte nochmal. Ein Copy 'n Paste der Fehlermeldung würde raten auch vermeiden...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KaeseGewitter » 04. September 2005 16:26

Der Befehl war "RCTP". Welcher Befehl das war ist aber auch wieder wurscht, da wenn ich das Script auf einem anderen Webserver ausführe kennt der SMTP Server den Befehl, es liegt also entweder an meinem Rechner oder an dem Xampp server. An meinem Rechner kann es wiederum nicht liegen, da ich ja auch per Thunderbird mails ersenden kann und der macht ja im prinzip nichts anderes.
KaeseGewitter
 
Posts: 5
Joined: 04. September 2005 15:08

Postby Wiedmann » 04. September 2005 16:36

Sorry, aber du bist sicher das du hier Hilfe suchst und haben willst?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KaeseGewitter » 04. September 2005 17:25

bis eben war ichs noch ;-) aber ich habe dann beschlossen, dass ich auf dem Webserver entwickle und nicht mehr auf localhost.
KaeseGewitter
 
Posts: 5
Joined: 04. September 2005 15:08


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests