PECL profiler apd xdebug phpize PEAR dbg

Alles, was PHP betrifft, kann hier besprochen werden.

PECL profiler apd xdebug phpize PEAR dbg

Postby Matreju » 30. July 2005 15:13

So,
vielleicht hat ja jemand eine Idee. Ich wollte einen Profiler / debugger wie APD oder Xdebug installieren mit lampp 1.4.13
Oki...Mit pear install ging es nicht. Also habe ich hier im Forum ne Lösung gefunden. Nun konte ich die Pakete compilieren. Aber keines der Module funktioniert. Kann mir jemand mal nen Tip geben ? Also die libs liegen schon an der richtigen stelle. Der findet irgendwelche Funktionen nicht.
Last edited by Matreju on 30. July 2005 21:26, edited 1 time in total.
Matreju
 
Posts: 25
Joined: 31. July 2004 11:56

Postby Wiedmann » 30. July 2005 15:26

Aber keines der Module funktioniert. Kann mir jemand mal nen Tip geben ? Also die libs liegen schon an der richtigen stelle. Der findet irgendwelche Funktionen nicht.

Wie äussert sich das "nicht funktionieren" und was findet er nicht? *rätsel*
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Matreju » 30. July 2005 15:29

/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/xdebug.so: undefined symbol: OnUpdateLong in Unknown on line 0

/opt/lampp/lib/php/extensions/no-debug-non-zts-20020429/apd.so: undefined symbol: OnUpdateLong in Unknown on line 0

Das sind die Fehler...
Matreju
 
Posts: 25
Joined: 31. July 2004 11:56

Postby Wiedmann » 30. July 2005 15:44

Und wann kommen die? Wohl beim Start vom Apache.

BTW:
Gibt es OnUpdateLong nicht erst in den PHP5.1 headern? Oder du hast die Extension mit den falschen Headern gebaut und versuchst es in der anderen Version zu laden. (du benutzt doch grad PHP4?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Matreju » 30. July 2005 15:48

Ich habe apd-0.9.2 ist für 4.x
und xdebug-1.3.2. Auch für xdebug

Zu testzwecken habe ich auch andere Versionen probiert. Immer das gleiche Prob.

Die Fehlermeldungen kommen beim start von apache..Jepp.
Matreju
 
Posts: 25
Joined: 31. July 2004 11:56

Postby Matreju » 30. July 2005 15:51

Nu habe ich quark erzählt....0.9.2 ging nicht zum compilieren. Habe gerade eben nochmal getestet.

/opt/lampp/bin/apd-0.9.2/php_apd.c: In function `apd_get_active_function_name':
/opt/lampp/bin/apd-0.9.2/php_apd.c:306: error: structure has no member named `ce'
/opt/lampp/bin/apd-0.9.2/php_apd.c:307: error: structure has no member named `ce'
/opt/lampp/bin/apd-0.9.2/php_apd.c:313: error: request for member `ptr' in something not a structure or union
/opt/lampp/bin/apd-0.9.2/php_apd.c:314: error: request for member `ptr' in something not a structure or union
/opt/lampp/bin/apd-0.9.2/php_apd.c: At top level:
/opt/lampp/bin/apd-0.9.2/php_apd.c:470: error: `OnUpdateInt' undeclared here (not in a function)
/opt/lampp/bin/apd-0.9.2/php_apd.c:470: error: initializer element is not constant
/opt/lampp/bin/apd-0.9.2/php_apd.c:470: error: (near initialization for `ini_entries[1].on_modify')
/opt/lampp/bin/apd-0.9.2/php_apd.c:470: error: initializer element is not constant
/opt/lampp/bin/apd-0.9.2/php_apd.c:470: error: (near initialization for `ini_entries[1]')
/opt/lampp/bin/apd-0.9.2/php_apd.c:471: error: initializer element is not constant
/opt/lampp/bin/apd-0.9.2/php_apd.c:471: error: (near initialization for `ini_entries[2]')
make: *** [php_apd.lo] Error 1

Nur die 0.9.1 ging zu compilieren..Aber xdebug gab es keine Probleme.Weder bei 1.3.2 noch bei 2.0
Matreju
 
Posts: 25
Joined: 31. July 2004 11:56

Postby Matreju » 30. July 2005 17:10

So..Nun ist mir aufgefallen das ich gar keine PECL libs funktionsfähig compilieren kann.
Status ist das ich das passende dev Pakete der xampp habe und mich an die configure Anleitung aus diesem Forum hier gehalten habe.
Wenn ich z.B apd 0.9.2 gegen meine Standard php von SuSE 9.2 compiliere gelingt es zwar. Aber der xampp Apache sagt dann apd.so ist wohl keine PHP Lib. Hat da irgendjemand ne Idee ?
Ablauf für xampp ist ungefähr :
/opt/lampp/bin/pear download aps-0.9.2
dann entpacken
wechseln ins Verzeichniss
/opt/lampp/bin/phpize
./configure --prefix /opt/lampp --enable apd --with-php-config=/opt/lampp/bin/php-config

Im Makefile wird das INCLUDES mit-I/opt/lampp/includes erweitert
dann make und make install
Es wird auch alles schön artig ins richtig lampp extensions verzeichnis kopiert.

Aber das wars dann auch.
Matreju
 
Posts: 25
Joined: 31. July 2004 11:56


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest