mail()

Alles, was PHP betrifft, kann hier besprochen werden.

mail()

Postby tz » 29. July 2005 00:50

Hallo Forum,

mal ne ganz dumme Frage, meine mail()-Funktion funzt ned, weil wahrscheinlich der SMTP-Server nicht konfiguriert oder installiert ist!?

Wie bekomme ich den zum laufen?
Hab en Windows-System.

Gruß
TZ
tz
 
Posts: 14
Joined: 05. December 2004 22:56

Postby deepsurfer » 29. July 2005 08:40

entweder einen Aussenstehenden Mailserver benutzen oder wenn du XAMPP benutzt ist ein Mailserver mit vorhanden im Paket. (MercuryMailserver)

Ansonsten findet man über Google einige Windows-Mailserver zum Download.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby jakimo72 » 29. July 2005 21:01

Du benötigst für die Funktion
mail()
einen SMTP-Server ohne Authentifikation.
Heutzutage sollte sich ein solcher (hoffendlich) nicht mehr
im Internet zu finden sein.

2 Lösungsansätze:
- anstelle von mail() die Klasse Pear-Mail verwenden, da kann man
auch SMTP-Server mit Authentifikation einstellen.
sehe auch
http://community.apachefriends.org/f/viewtopic.php?t=10244

- anstelle eines externen SMTP-Server einen eigenen
local einsetzen. ich verwende dazu immer
das Programm SMTPAuth, da es schön einfach ist.
http://sourceforge.net/projects/smtpauth


Gründlich haben wir das Problem (mit reichlich Missverständnissen)
auch im folgenden Thread erörtert:
http://community.apachefriends.org/f/viewtopic.php?t=12307
User avatar
jakimo72
 
Posts: 151
Joined: 07. February 2005 13:25
Location: Hamburg-Barmbek

Postby tz » 01. August 2005 21:49

hi,

danke für die info's!

jetzt habe ich nur noch ein problem mit SMTPAuth. nachdem ich ein konto eingerichtet habe, der status auf warten gesetzt ist, scheint mein mail-script sich in einen dauer-warte-zustand versetzt zu haben. wenn ich SMTPAuth beende, geht das script weiter. muss ich bestimmte einstellungen berücksichtigen? oder gibt es vielleicht noch etwas was ich der php.ini ändern muss?

gruß
tz
tz
 
Posts: 14
Joined: 05. December 2004 22:56

Postby jakimo72 » 02. August 2005 09:31

Ich weiss nicht, warum Dein Script stehenbleibt,
in der PHP.ini ist unter Win32 nur einzustellen:
Code: Select all
[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = DEINE@EMAIL.DE

; Optional for Win32 only.
smtp_port = 25

Wobei Du natürlich sendmail_from richtig einstellen solltest.

P.S.
Bei einigen Providern kann man anstellen von Authentifikation
für SMTP auch die Funktion "STMP after POP" einstellen, dann funktioniert alles nicht! Also Authentifikation mit SMTP einstellen!
Viele Provider erlauben noch keine sichere Authentifikation mit Verschlüsselung. In SMTPAuth die Methode AUTH PLAIN einstellen.
Viele Provider achten peinlichst darauf, dass der Absendername (sehe PHP.ini) auch richtig ist.
User avatar
jakimo72
 
Posts: 151
Joined: 07. February 2005 13:25
Location: Hamburg-Barmbek

Postby tz » 02. August 2005 10:02

Hallo,

die php.ini sieht bei mir genau so aus.

Mit Local SMTP Relay Server funktionierts ohne Probleme, allerdings landen die Maisl im Spam-Ordner.

Wo kann man denn die Authentifikation in SMTPAuth einstellen?
Also AUTH PLAIN ist eingestellt!

Vielleicht ist auch meine Version en bisle bugi, 2.00 Beta 3, welche verwendest du?

Gruß
TZ
tz
 
Posts: 14
Joined: 05. December 2004 22:56

Postby jakimo72 » 02. August 2005 10:42

Authentifikation über SMTP wird bei Deinem Provider
eingestellt,
z.B. bei GMX unter
"GMX Homepage - Mein GMX - E-Mail - Optionen - Sicherheit"

Ganz wichtig ist, dass die Absenderadresse in der PHP.ini richtig
eingestellt ist, denn einige Spamfilter mögen es gar nicht, wenn
des Absender nicht mit dem Provider übereinstimmt.

Du solltest in den Mails, die Du versendest nicht die
Wörter
cheep Meds, Viagra, Bank of Nigeria usw.
verwenden....
User avatar
jakimo72
 
Posts: 151
Joined: 07. February 2005 13:25
Location: Hamburg-Barmbek

Postby tz » 02. August 2005 11:03

jakimo72 wrote:Authentifikation über SMTP wird bei Deinem Provider
eingestellt,
z.B. bei GMX unter
"GMX Homepage - Mein GMX - E-Mail - Optionen - Sicherheit"

hab ich!

jakimo72 wrote:Ganz wichtig ist, dass die Absenderadresse in der PHP.ini richtig
eingestellt ist, denn einige Spamfilter mögen es gar nicht, wenn
des Absender nicht mit dem Provider übereinstimmt.

hab ich!

jakimo72 wrote:Du solltest in den Mails, die Du versendest nicht die
Wörter
cheep Meds, Viagra, Bank of Nigeria usw.
verwenden....

hab ich nicht!

keine ahnung warum es nicht geht!? ich werde mal ein anderes programm ausprobieren, wie gesagt, mit Local SMTP Relay Server funzt es! früher hatte ich sendmail für windows, du hast nicht zufällig en link dazu? irgendwie find ich das nämlich nicht mehr...

gruß
tz
tz
 
Posts: 14
Joined: 05. December 2004 22:56

Postby deepsurfer » 02. August 2005 11:06

Sendmail ist bei XAMPP für Windows dabei ansonsten
http://glob.com.au/sendmail/
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest