exec-Familie hängt sich auf

Alles, was PHP betrifft, kann hier besprochen werden.

exec-Familie hängt sich auf

Postby PeterB » 11. April 2005 10:17

Hallo,

Ich habe ein Problem mit der gesammten Exec familie (popen, system und exec).

Manchmal hängt sich der befehl auf und macht nichts mehr. Apache und andere php scripte laufen wie gewohnt weiter. Ich habe bereits in den bugreoprts von php gesucht. nur leider nichts wirklich gefunden, was Ursache des problemes sein könnte. Es gibt etliche report, dass die Session in dem Zusammenhang Probleme macht. Aber die Workarounds habe ich bereits ohne Erfolg ausprobiert.

Das größte Problem ist allerdings, das es sehr launisch ist. Sprich: ich kann es nur selten reproduzieren.

Kennt jemand von euch diesen Fehler?

Mein Setup:

Apache 2.0.48
PHP 4.3.4
Windows 2000 server
PeterB
 
Posts: 11
Joined: 15. February 2005 22:21

Postby Stefan » 11. April 2005 12:59

Grüß Dich,

Gerade im Moment benutze ich auch die Funktionen, bisher habe ich nichts feststellen können. Vielleicht stimmt ja was mit dem nicht, das Du damit startest.

Viel Erfolg!

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby PeterB » 11. April 2005 14:43

benutzt du auch die GLeichen Versionen wie ich? Das Project an dem ich arbeite ist ein komplett ausgewachsenes Großproject. Das problem ist der gleiche befehl funktioniert ab und zu und ab und zu funktioniert er eben nicht. genau das ist das Problem....

Peter
PeterB
 
Posts: 11
Joined: 15. February 2005 22:21

Postby Stefan » 11. April 2005 16:25

Servus,

ja, gleiche Versionen.
Ich hoffe Du findest eine Lösung, denn für ein ausgewachsenes Großprojekt sind hänger eher schlecht.

Viel Erfolg!

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests