php unsicher im sicherheits-check - nanu

Alles, was PHP betrifft, kann hier besprochen werden.

php unsicher im sicherheits-check - nanu

Postby toffelsen » 07. April 2005 10:33

Obwohl ich in diversen php.ini´s ( zuerst die \php\php5.ini, dann die \php\php.ini und schließlich die \apache\bin\php.ini ) den safe mode Eintrag geändert hatte ( OFF -> ON ), bekam ich im Sicherheits-Check immer nur php unsicher gemeldet. Warum?
toffelsen
 
Posts: 4
Joined: 07. April 2005 10:26

Postby Hanspeter Thöni » 07. April 2005 13:18

Nur eine kleine Rückfrage: Den apachen hast du aber schon neu gestartet nach der Aenderung?
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby toffelsen » 07. April 2005 14:44

Natürlich habe ich das jedes Mal gemacht. Ganz Anfänger bin ich mit so Sachen eigentlich nicht... :-)
toffelsen
 
Posts: 4
Joined: 07. April 2005 10:26

Postby deepsurfer » 07. April 2005 17:28

gerade eben mit einer frischen XAMPP install gegengetestet.

wenn ich in der \xampp\apache\bin\ die php.ini editiere und auf Safe on setze, wird der check auch richtig gesetzt.

MIt welchem Editor hast du die INI editiert ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby toffelsen » 07. April 2005 18:09

Ich habe das ejtzt auch geschafft. Állerdings hat´s erst funktioniert, als ich auch noch die \php\php.ini geändertt hatte. Merkwürdig, oder?
toffelsen
 
Posts: 4
Joined: 07. April 2005 10:26

Postby toffelsen » 07. April 2005 18:15

nachsatz.
um es genau zu wissen, habe ich jtzt gegengeprüft.
was zieht, ist in meinem fall nicht die \apache\bin\php.ini
sondern die \xampp\php\php.ini

was gestern noch falsch lief, war vermutlich, dass ich immer den parameter darunter gleich mitgeändert hatte: safe_mode_gid
toffelsen
 
Posts: 4
Joined: 07. April 2005 10:26

Postby deepsurfer » 07. April 2005 18:27

toffelsen wrote:nachsatz.
um es genau zu wissen, habe ich jtzt gegengeprüft.
was zieht, ist in meinem fall nicht die \apache\bin\php.ini
sondern die \xampp\php\php.ini


rufe phpinfo auf dort wird dir die INI angezeigt die benutzt wird...
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to PHP

Who is online

Users browsing this forum: No registered users and 4 guests