mail() und der E-Mail Header

Alles, was PHP betrifft, kann hier besprochen werden.

mail() und der E-Mail Header

Postby AlexPausB » 14. March 2005 09:02

Servus,

ich bin zu einem anderen Webhoster umgezogen und seitdem habe ich das Problem, dass E-Mails aus Formularen heraus, die Headerinformationen in die Mail schreiben... folgendes wird quasi in den Body der Mail geschrieben:

Code: Select all
Content-type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: 8Bit
From: "Webmaster TV-Burgholzhausen" <webmaster@tv-burgholzhausen.de>
X-Mailer: PHP/4.3.10
Message-Id: <20050310151326.2B56D1A001D@mail.basicmotion.de>
Date: Thu, 10 Mar 2005 16:13:26 +0100 (CET)


Mein Provider sagte mir, dass es an den Unterschieden von Windows und Linux liegt - was m.E. Blödsinn ist. Vorher lief das Script auch unter Linux und es hat einwandfrei funktioniert.

Hat jemand ne Idee, woran das liegen könnte?

Danke und Gruß
Alex
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Stefan » 14. March 2005 14:16

Servus,
Mein Provider sagte mir, dass es an den Unterschieden von Windows und Linux liegt - was m.E. Blödsinn ist. Vorher lief das Script auch unter Linux und es hat einwandfrei funktioniert.

Vielleicht läuft ja jetzt Windows :-)

Wo/Wie wird die Mail zusammengebaut?

Versuchs mal mit Klassen wie folgenden
http://www.phpguru.org/static/mime.mail.html
oder wenn Du PEAR benutzen kannst
http://pear.php.net/package/Mail_Mime/

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby AlexPausB » 14. March 2005 15:31

Stefan wrote:Vielleicht läuft ja jetzt Windows :-)


Noooin :)

Stefan wrote:Wo/Wie wird die Mail zusammengebaut?


Ja wie wo? (:

Formular wird ausgefüllt, wenn alle Bedingungen erfüllt sind
kommt mail($to, $subject, $body, $header);

Fertisch.

Stefan wrote:Versuchs mal mit Klassen wie folgenden
http://www.phpguru.org/static/mime.mail.html
oder wenn Du PEAR benutzen kannst
http://pear.php.net/package/Mail_Mime/


Ja aber... wieso? Es muss doch einen Grund geben,
warum das nicht mehr funzt. Die Klasses wurden mir
auch vom Admin empfohlen, verstehe nur nicht den Grund...

Daaanke und wech...
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Wiedmann » 14. March 2005 15:44

mail($to, $subject, $body, $header);

Stefean meinte, wo und wie diese Variablen gefüllt werden. Schätzungsweise fehlt dir aber ein "\n" im Header.

Die Klasses wurden mir
auch vom Admin empfohlen, verstehe nur nicht den Grund...

Weil diese Klassen ausgereift sind, und normal wissen wie eine korrekte Mail auszusehen hat (, im Gegensatz zu manchem PHP-Programmierer der das von Hand machen will).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby AlexPausB » 14. March 2005 15:53

Wiedmann wrote:
mail($to, $subject, $body, $header);

Stefean meinte, wo und wie diese Variablen gefüllt werden. Schätzungsweise fehlt dir aber ein "\n" im Header.



Mein Header schaut momentan so aus:

Code: Select all
$header  = "MIME-Version: 1.0\r\n";
$header .= "Content-type: text/plain; charset="ISO-8859-1"\r\n";
$header .= "Content-Transfer-Encoding: 8Bit\n";
$header .= "From: " . $_POST["Name"] . "<" . $_POST["Email"] . ">\r\n";
$header .= "X-Mailer: PHP/" . phpversion();


Weil diese Klassen ausgereift sind, und normal wissen wie eine korrekte Mail auszusehen hat (, im Gegensatz zu manchem PHP-Programmierer der das von Hand machen will).


Also so wie ich :? - Deswegen frage ich ja nach, woran das liegt. Und ich frage mich warum es auf Linux A funzt, auf Linux B aber nicht.

Danke und Gruß
Alex
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby chrigu99 » 17. March 2005 18:34

in der 3. zeile beim encoding fehlt doch ein \r?
und in der letzten zeile sollte doch ebenfalls \r\n hin?

grüsse
Praxis: Jeder kann´s, aber keiner weiß wie´s geht...
Theorie: Jeder weiß wie´s geht, aber keiner kann´s ...
Microsoft vereint Praxis und Theorie: Nix geht und keiner weiß warum
User avatar
chrigu99
 
Posts: 114
Joined: 30. May 2003 10:55
Location: Bern, Schweiz (*jodel, jodel hihihihihi*)

Postby AlexPausB » 21. March 2005 16:06

Noin... auch das bringt keine Abhilfe. Ich verstehe einfach nicht, warum das auf diesem NICHT funktioniert.
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf


Return to PHP

Who is online

Users browsing this forum: No registered users and 1 guest