Probleme mit ImageCreateFromJPEG

Alles, was PHP betrifft, kann hier besprochen werden.

Probleme mit ImageCreateFromJPEG

Postby jakimo72 » 08. February 2005 14:45

Hallo ich habe ein Problem mit folgendem Script:

Code: Select all
<?php
echo "Vorher<br>";
$filename = "DSCF0017.JPG";
$im = @ImageCreateFromJPEG($filename);
echo "Nachher<br>";
?>


Ich benutze XAMPP 1.4.11 unter Suse Linux 9.2 (Kernel 2.6.8).

Wenn ich ein Bild > 600 Kb angeben wird das Script gar nicht ausgeführt,
mit kleinen Bildern klappt es. Wenn ich auf PHP4 zurückschalte
kommt er bis "Vorher<br>".

Es gibt keine Fehlermeldung, keine Warning, keine Notice.
IE sagt, er könne die Seite nicht anzeigen, Firefox sagt noch nicht einmal das.

Unter Win32 gibt es überhaupt keine Probleme.


Woran kann das liegen?
User avatar
jakimo72
 
Posts: 151
Joined: 07. February 2005 13:25
Location: Hamburg-Barmbek

Postby Benzman » 10. February 2005 11:03

Mach mal das @ vor ImageCreateFromJPEG weg, da dieses Bewirkt, dass PHP keine Fehlermeldung ausgibt.
User avatar
Benzman
 
Posts: 132
Joined: 27. July 2003 18:46
Location: Bayern

Postby jakimo72 » 11. February 2005 11:31

Gruss, und hilft nix.
hab' ich schon versucht.

also folgende Befehle funktionieren nur mit kleinen Dateien:
$im = @ImageCreateFromJPEG($filename);
$im = ImageCreateFromJPEG($filename);
$im = @imagecreatefromjpeg($filename);
$im = imagecreatefromjpeg($filename);
User avatar
jakimo72
 
Posts: 151
Joined: 07. February 2005 13:25
Location: Hamburg-Barmbek


Return to PHP

Who is online

Users browsing this forum: No registered users and 4 guests