Hilfeeeee !!!!

Alles, was PHP betrifft, kann hier besprochen werden.

Hilfeeeee !!!!

Postby svenny2005 » 03. February 2005 12:17

Hallo habe folgendes Problem :

ich habe eine Homepage auf meinem Computer also per Dyn.DNS Update habe den Xampp installiert und die Homepage mit phpkit erstellt aber bei phpkit klappt der E-Mail Versand nicht wenn sich einer registieren will da kommt die Meldung "Ihre E-Mail konnte nicht gesendet werden. Versuchen sie es später erneut" ! So in der Einstellung von phpkit bei E-mail Versant steht da SMTP Server was muss ich da eintragen ich habe es mit MecuryMail versucht aber das ist mir zu komplizeirt jetzt hab ich den Hamster am laufen *g* aber ich weis auch nicht was genau ich da einstellen muss damit er die Mails versendet von meinem web.de Konto an meine User die sich auf meiner HP registieren wollen. Bitte helft mit ich habe auch die Seite von http://hamster.volker-gringmuth.de/ durchgelesen aber das bringt mir auch nicht weiter irgendwie ! Ich will nur das Hamster die Mails von meinname@web.de an die Mail-Adressen schickt die meine User dort angegben haben bei der registiertung mehr nicht !

Hoffe einer kann mir helfen danke im Vorraus
svenny2005
 
Posts: 7
Joined: 03. February 2005 12:04

Postby adi99 » 03. February 2005 12:34

Hallo,

miniRelay ist da eine super Lösung.

http://netvicious.iespana.es/netvicious ... iRelay.zip

http://www.batworld.net/modules.php?op= ... e&artid=58



PS: Diese Links sind aus diesem Forum!!!
User avatar
adi99
 
Posts: 115
Joined: 15. January 2004 16:08
Location: Switzerland

Postby svenny2005 » 03. February 2005 12:53

so habe jetzt minirelay gedownloadet und so eingestellt wie es da steht auf der seite, was mache ich nun damit phpkit e-mails versendet an die e-mail adressen fremder user ? Was trage ich bei phpkit bei SMTP Server ein ? Ich kapier das irgendwie nicht. Ein User gibt seine E-mail Adresse ein daraufhin sendet doch phpkit dem User eine E-Mail über einen SMTP-Server den man bei phpkit im Adminbereich eingegeben hat aber wieso gibts da kein Benutzername und Pw dann könnte ich doch angeben smtp.web.de ach kein plan komm ich mal auf minirelay zurück bei smtp server muss ich also irgendwas eingeben dann sendet phpkit die e-mail adresse des Users an minirelay und minirelay sendet das dann über meine E-Mail Adresse von web.de zu ihm aber ich kann bei minirelay nix eingeben mit smtp.web.de oder wie funktioniert das denn alles ?
svenny2005
 
Posts: 7
Joined: 03. February 2005 12:04

Postby adi99 » 03. February 2005 14:44

du must localhost als deinen SMTPserver angeben
User avatar
adi99
 
Posts: 115
Joined: 15. January 2004 16:08
Location: Switzerland

Postby svenny2005 » 03. February 2005 14:58

ok ich habe bei phpkit im admin bereich localhost als smtp server eingegeben so muss ich sonst noch was einstellen vieleicht in der php.ini von xampp ? Es funzt immer noch nicht
svenny2005
 
Posts: 7
Joined: 03. February 2005 12:04

Postby adi99 » 03. February 2005 15:10

theotretisch musst du in der php.ini nichts verändern

Code: Select all
[mail function]
; For Win32 only.
SMTP = localhost



So müsste es sein!

Ich bin jetzt gerade auf der PHPKIT Page gesehen das du das Feld "SMTP-Mailserver" leerlassen musst!!!!
User avatar
adi99
 
Posts: 115
Joined: 15. January 2004 16:08
Location: Switzerland

Postby svenny2005 » 03. February 2005 15:20

ja wusste ich nicht ich hab jetzt im adminbereich smtp server freigelassen so jetzt wenn ich auf meiner page auf passwort vergessen klicke und meine e-mail angebe steht da "An die angegebene Email-Adresse wurde ein provisorischer Direktlink zu Ihrem Benutzerprofil gesendet.

Nach dem Login, können Sie ein neues Passwort in Ihrem Benutzerprofil festlegen." so dann hat er eine E-Maiul versand und bei minirelay server kamm die meldung "15:02:28 Listening on 127.0.0.1 (Port 25)
15:02:28 Listening on 10.10.100.2 (Port 25)
15:11:40 Command: MAIL FROM <localhost>
15:11:40 Command: RCPT TO <Invisible-Hunter@web.de>
15:11:42 Command: MAIL FROM <localhost>
15:11:42 Command: RCPT TO <Invisible-Hunter@web.de>
15:11:42 [1] Mx Domain of web.de cached
15:11:42 [1] Connected with mx-ha01.web.de
15:11:42 [1] Error Connection Closed Gracefully."

in meine php.ini steht

[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = postmaster@localhost

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =

so was mach ich da falsch ?

So hab wieder was neues rausgefunden. Wenn ich mich registirere mit Webmaster@feuerwehr-lorch.de dann sendet der die mail an webmaster@feuerwehr-lorch.de und ich bekomme die mail auch und bei Passwort vergessen bekomme ich auch die mail mit meinem passwort aber wenn ich jetzt mich registrieren will mit svenrasel@msn.com dann geht das wieder nicht ! Weis einer was da los ist ? Hab in der php.ini was geändert die sieht jetzt so aus
Code: Select all
[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = invisible-hunter@web.de

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =


und minirelay zeigt das an
Code: Select all
16:43:40 Command: MAIL FROM <invisible-hunter@web.de>
16:43:40 Command: RCPT TO <webmaster@feuerwehr-lorch.de>
16:43:40 Command: MAIL FROM <invisible-hunter@web.de>
16:43:40 Command: RCPT TO <webmaster@feuerwehr-lorch.de>
16:43:40 [3] Mx Domain of feuerwehr-lorch.de cached
16:43:40 [3] Connected with mailin.webmailer.de
16:43:41 [3] Sending message
16:43:41 [3] Message successfully sent


so hab noch ein test gemacht bin an den pc von meinem vadder gegangen und bin dann auf meine homepage geangen hab mich registirert und minirelay hat das angegeben dann
Code: Select all
17:08:03 Command: MAIL FROM <invisible-hunter@web.de>
17:08:03 Command: RCPT TO <klausrasel@gmx.de>
17:08:03 Command: MAIL FROM <invisible-hunter@web.de>
17:08:03 Command: RCPT TO <klausrasel@gmx.de>
17:08:04 [12] Mx Domain of gmx.de cached
17:08:04 [12] Connected with mx0.gmx.de
17:08:04 [12] Sending message
17:08:04 [12] Error 5.7.1 {mx015} The recipient does not accept mails from 'web.de' over foreign mailservers
17:08:04 [12] Connected with mx0.gmx.de
17:08:05 [12] Error 5.7.1 {mx034} The recipient does not accept mails from 'web.de' over foreign mailservers
17:08:05 [12] Connected with mx0.gmx.de
17:08:05 [12] Error 5.7.1 {mx003} The recipient does not accept mails from 'web.de' over foreign mailservers
17:08:05 [12] Connected with mx0.gmx.net
17:08:05 [12] Sending message
17:08:06 [12] Error 5.7.1 {mx056} The recipient does not accept mails from 'web.de' over foreign mailservers
17:08:06 [12] Connected with mx0.gmx.net
17:08:11 [12] Error 5.7.1 {mx011} The recipient does not accept mails from 'web.de' over foreign mailservers
17:08:11 [12] Connected with mx0.gmx.net
17:08:11 [12] Error 5.7.1 {mx019} The recipient does not accept mails from 'web.de' over foreign mailservers
17:08:11 [12] El mensaje no ha podido ser enviado. Se queda en la cola


so was könnte das sein ? Bitte helft mir
svenny2005
 
Posts: 7
Joined: 03. February 2005 12:04


Return to PHP

Who is online

Users browsing this forum: No registered users and 2 guests