Apache 1.3.27 + mod_ssl + OpenSSL + Win32

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 1.3.27 + mod_ssl + OpenSSL + Win32

Postby Micro Glotz » 29. April 2003 18:22

Hi Leuts

Ich habe lokal einen Apache 1.3.27 unter Win2000 laufen.
Soweit alles perfekt.

Die Module mod_ssl sowie OpenSSL sind mit einkompiliert worden beim erstellen.
Sie funktionieren auch.
Apache läuft voll auf DNS und zusätzlich auf dynamischen IP Adressen mit virtuellen Hosts.

Ich habe normal HTTP oder HTTPS keine Probleme über die angelegten lokalen URL's oder die Internet IP auf die Kiste zuzugreifen.

Nun mein Problem. Ich bekomme beides gleichzeitig, also HTTP und HTTPS nicht zum laufen.
Es geht entweder das eine oder andere. Schalte ich "Listen 443" hinzu, geht nur noch HTTPS, HTTP findet er dann keinen Server. Kommentiere ich das aus, geht nur noch HTTP.


Mal zum vergleichen die Auszüge auf der httpd.conf, kann ja sein es fällt irgendwem etwas auf.

LoadModule ssl_module modules/mod_ssl.so
AddModule mod_ssl.c

Port 80

# Kein Servername angegeben, auch keine Bind Adresse

.
.
.
.

## BEGIN SSL CONFIG

#Listen 443
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
CustomLog h:/programme/apache2/logs/ssl.request.log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

## END SSL CONFIG


include conf/virtual.hosts.conf


- Inhalt virtual.hosts.conf –

NameVirtualHost *

<VirtualHost *:443>
ServerName www.wutzel.home
ServerAlias *.wutzel.home wutzel.home
DocumentRoot h:/programme/apache2/htdocs
ScriptAlias /cgi-bin/ h:/programme/apache2/cgi-bin/
SSLEngine off
SSLCertificateFile conf/ssl/micro.crt
SSLCertificateKeyFile conf/ssl/micro.key
# ErrorLog H:/WebLogs/wutzel/error.log
# CustomLog H:/WebLogs/wutzel/access.log combined
# DirectoryIndex index.cgi index.htm index.php index.php3 index.php4 index.pl
</VirtualHost>

<VirtualHost *>
ServerName www.wutzel.home
ServerAlias *.wutzel.home wutzel.home
DocumentRoot h:/programme/apache2/htdocs
ScriptAlias /cgi-bin/ "h:/programme/apache2/cgi-bin/"
ServerAdmin microg@gmx.net
ErrorLog H:/WebLogs/wutzel/error.log
CustomLog H:/WebLogs/wutzel/access.log combined
DirectoryIndex index.cgi index.htm index.php index.php3 index.php4 index.pl
</virtualHost>

<VirtualHost *>
ServerAdmin microg@gmx.net
DocumentRoot d:/GlotzMi/Entwicklung/CVSROOT
ScriptAlias /cgi-bin/ "h:/programme/apache2/cgi-bin/"
ServerAlias *.cvs.home cvs.home
ServerName www.cvs.home
ErrorLog H:/WebLogs/cvsroot/error.log
CustomLog H:/WebLogs/cvsroot/access.log combined
DirectoryIndex index.cgi index.htm index.php index.php3 index.php4 index.pl
</virtualHost>

.
.
.
.


### ENDE ###


Wo steckt der Fehler?!

Ideen?
Micro Glotz
 

Postby Micro Glotz » 29. April 2003 18:24

Noch etwas:

Das bringt er, ganz vernünftig, bei apache -S


C:\>h:\programme\apache2\apache -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:443 www.wutzel.home (h:/programme/apache2/conf/virtual.hosts.conf:21)
*:80 is a NameVirtualHost
default server www.wutzel.home (h:/programme/apache2/conf/virtual.hosts.conf:34)
port 80 namevhost www.wutzel.home (h:/programme/apache2/conf/virtual.hosts.conf:34)
port 80 namevhost www.cvs.home (h:/programme/apache2/conf/virtual.hosts.conf:45)
port 80 namevhost www.phpadmin.home (h:/programme/apache2/conf/virtual.hosts.conf:56)
Micro Glotz
 


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests