5 Sekunden Delays bei Zugriff auf Virtual Hosts

Alles, was den Apache betrifft, kann hier besprochen werden.

5 Sekunden Delays bei Zugriff auf Virtual Hosts

Postby luminol » 30. December 2004 18:46

Hallo zusammen,
bereits seit gestern Abend versuche ich mich an einer korrekten Konfiguration der httpd.conf unter Windows XP.

Folgendes Problem: Ich verwende sowol die XAMPP Standardseiten als auch eine extra "Domain" innerhalb einer Virtual Host Konfiguration.
Der Zugriff auf den Standard XAMPP Content (der auch global als DocumentRoot und ServerName festgelegt wurde) bereitet keine Probleme, lediglich der "sekundäre" Virtual Host - bei jedem Browser Neustart (Opera, IE) dauert es konsequent 5 Sekunden, bis der Content lokalisiert und daraufhin angezeigt wird. Wenn ich nun nach einer gewissen Zeit den Content im Browser refreshen möchte, geht der Spuk von vorne los. Ich kann mir nicht erklären, an was das liegen könnte.

Es sind zwar nur 5 Sekunden, auf Dauer ist das allerdings etwas nervtötend, wenn man schnell eine Seite refreshen möchte und dann wieder 5 Sekunden warten darf..

Desweiteren habe ich testweise meinen "sekundären" Virtual Host als primären deklariert (zu Beginn der VirtualHost Direktive), das globale DocumentRoot angepasst, was keine Verbesserung der Lage mit sich bringt - in diesem Fall entsteht der 5 Sekunden Delay beim XAMPP Content.

Anbei die entsprechenden Fragmente innerhalb der httpd.conf:

Global definiert:
Code: Select all
Listen 127.0.0.1:80
ServerName localhost
DocumentRoot "C:/Programme/Net/apachefriends/xampp/htdocs"

Virtual Host spezifisch:
Code: Select all
NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0.0.1:80>
 DocumentRoot "C:/Programme/Net/apachefriends/xampp/htdocs"
 ServerName   localhost
</VirtualHost>

<VirtualHost 127.0.0.1:80>
 DocumentRoot "C:/Dokumente und Einstellungen/User/Eigene Dateien/web/domains/testbits"
 ServerName   testbits.local
</VirtualHost>


In der entsprechenden Windows 'hosts' Datei sind folgende Einträge verzeichnet:
Code: Select all
127.0.0.1     localhost
127.0.0.1     testbits.local

Der Apache Server soll dabei ausschließlich auf die lokale IP (127.0.0.1) hören.

Inzwischen sind mir die Ideen ausgegangen, was ich in den Konfigurationen noch ändern könnte, um diese Delays zu verhindern.

Das Problem habe ich sowohl unter XAMPP-1.4.9 als auch 1.4.11 (1.4.10 habe ich augrund der PHP4-MySQL Inkompatibilitäten übersprungen).

Für jede Hilfe bin ich dankbar. :)




Gruß,
luminol
luminol
 
Posts: 3
Joined: 30. December 2004 18:12

Postby BMF » 30. December 2004 22:00

Hi,

NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0.0.1:80>
DocumentRoot "C:/Programme/Net/apachefriends/xampp/htdocs"
ServerName localhost
</VirtualHost>

^^RICHTIG

<VirtualHost 127.0.0.1:80>
DocumentRoot "C:/Dokumente und Einstellungen/User/Eigene Dateien/web/domains/testbits"
ServerName testbits.local
</VirtualHost>

^^FALSCH
XAMPP ist meist unter C:/apachefriends/xampp installiert und du kannst keine Dateien/Ordner außerhalb htdocs aufrufen, sei es von localhost, sei es von www. ... .de. du hättest beim zweiten den Ordner "domains" oder "testbits" in "htdocs" kopieren müssen und dann musst du den DocumentRoot Pfad so angeben "C:/Programme/Net/apachefriends/xampp/htdocs/domains/testbits", das wäre richtig.

Zu Opera kann ich nur sagen: GRÖßTER SCHROTT ALLER ZEITEN :evil:
nimm dafür lieber Mozilla oder Mozilla Firefox.
Wenn du den Server startest, dauert es 5 Sekunden, bis diese Seite kommt welche Sprache du auswählen sollst?? normal!! wenn man einen langsamen Rechner hat, weil wenn der Server gestartet wird lädt der erstmal alle Dateien, zum Schluss lädt der dann die Seite http://localhost/xampp/splash.html. Das ist bei meinem alten Rechner genauso.

Viele Grüße
BMF

PS: Falls etwas daran falsch sein sollte, kann er mich ja korrigieren :D
Irren ist menschlich. Aber um richtigen Mist zu bauen, braucht man einen Computer.
User avatar
BMF
 
Posts: 101
Joined: 29. December 2004 18:19
Location: NRW

Postby luminol » 31. December 2004 01:26

Zunächst: Danke für Deine Bemühungen. :)

BMF wrote:
XAMPP ist meist unter C:/apachefriends/xampp installiert und du kannst keine Dateien/Ordner außerhalb htdocs aufrufen, sei es von localhost, sei es von www. ... .de. du hättest beim zweiten den Ordner "domains" oder "testbits" in "htdocs" kopieren müssen und dann musst du den DocumentRoot Pfad so angeben "C:/Programme/Net/apachefriends/xampp/htdocs/domains/testbits", das wäre richtig.



Das sollte unerheblich sein. Unter BSD bzw. anderen Unix artigen Systemen spielt es keine Rolle, ob ich der einen VirtualHost z.B. den DocumentRoot Pfad /var/www/htdocs, und der anderen /home/www/domain1 zuteile . Möglicherweise ist es unter Windows anders, was mich nicht mal verwundern würde - da ist so einiges anders. :P


Zu Opera kann ich nur sagen: GRÖßTER SCHROTT ALLER ZEITEN :evil:
nimm dafür lieber Mozilla oder Mozilla Firefox.


Geschmackssache. Nutze Opera seit Version 6.0 und hab ihn mir vor einiger Zeit sogar gekauft. 8)
Allerdings muss ich gestehen, dass mir die Firefox WebDev Extension ziemlich gut gefällt. Opera mangelt es in dieser Hinsicht an einigen nützlichen Features.
Operas GUI ist schnell (dank QT) und ich mag die vielen Shortcuts, hingegen ist Mozillas Interface (XUL) langsamer, dafür aber einfach erweiterbar, was die Existenz vieler Plugins erklärt.

Wenn du den Server startest, dauert es 5 Sekunden, bis diese Seite kommt welche Sprache du auswählen sollst?? normal!! wenn man einen langsamen Rechner hat, weil wenn der Server gestartet wird lädt der erstmal alle Dateien, zum Schluss lädt der dann die Seite http://localhost/xampp/splash.html. Das ist bei meinem alten Rechner genauso.


Meinte nicht _diese_ 5 Sekunden. ;-) localhost (mit Standard XAMPP Content) ist ohne Delays erreichbar, selbst wenn der Browser beendet und wieder gestartet wird. Vielmehr werden die alternativen Virtual Hosts in gewissen Zeitintervallen erst nach 5 Sekunden Delays angezeigt. Sobald diese 5 Sekunden "überstanden" sind, lassen sich die Seiten ohne weitere Delays refreshen, bis nach einiger Zeit erneut für 5 Sekunden gesucht wird. Und genau das finde ich etwas merkwürdig.

Naja, und einen 1.6 Ghz Pentium-M würde ich nicht unbedingt als langsam bezeichnen. ;) Selbst der OpenBSD Rechner (mit 200Mhz Pentium2 CPU) leistet hier gute Dienste als Router.


EDIT: Nachdem ich das ganze nun auch mit Firefox getestet habe und bei diesem die Seiten immerzu sofort angezeigt werden, gehe ich davon aus, dass die httpf.conf Konfiguration soweit stimmen sollte. Möglicherweise hängt es damit zusammen, in welcher Art und Weise die Clients (Opera, IE) Requests an der Server schicken und wie dieser mit jenen Requests umgeht. Selbst wenn sich Opera dem Server als Mozilla vorstellt, ändert das auch nichts. Naja..

Viele Grüße,
luminol
luminol
 
Posts: 3
Joined: 30. December 2004 18:12

Postby luminol » 03. January 2005 00:58

Ich habe nun den "Übeltäter" gefunden:

Dabei handelt es sich um den mDNS Prozess, der läuft, wenn man Apples Rendezvous Techology Preview 3 for Windows installiert hat.

Mit Hilfe von Rendezvous lassen sich Geräte im Netzwerk ansprechen, ohne dass viel konfiguriert werden muss - einfach ausgedrückt.
Das ist vor allem dann praktisch, wenn man einen nicht-unterstützten Drucker an eine Apple Base Station angeschlossen hat. ;)

Nun könnte es so sein, dass der IE und Opera (Firefox auch - nur gibts da keine Delays) stark von diesem mDNS Prozess Gebrauch machen, bevor sie auf die Idee kommen, mal in der Hosts Datei nachzuschauen - ob das wirklich in dieser Reihenfolge geschieht, kann ich nicht mit Gewissheit sagen. Auf alle Fälle hat sich das Problem erledigt, nachdem ich Rendezvous deinstalliert hatte, was zur Folge hatte, dass nun kein mDNS Prozess mehr läuft.

Inzwischen habe ich einen Bug Report auf Apple's Entwicklerseiten eröffnet und das Problem auch dem Opera Support mitgeteilt.

Falls also jemand in naher Zukunft Probleme mit seinen Virtual Hosts in Kombination mit Rendezvous hat - hier steht nun die Antwort. :)

Wer mehr über zeroconf erfahren möchte: http://de.wikipedia.org/wiki/Zeroconf

Gruß
luminol
luminol
 
Posts: 3
Joined: 30. December 2004 18:12


Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests