Verknüpfungen von Dateien funktionieren nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Verknüpfungen von Dateien funktionieren nicht

Postby ThomasD » 22. December 2004 15:03

Hallo miteinander,

ich habe folgendes Problem.

Zum Einen habe ich die Datei /var/www/cgi-bin/lxerp/am.pl
Diese Datei kann ich ohne Problme über den Webbrowser aufrufen.

Und ich habe zusätzlich noch die Date /var/www/cgi-bin/lxerp/Datev.pl
Hierbei handelt es sich um eine Verknüpfung zu der oben angebenen Datei.
Wenn ich diese Datei im Browser aufrufe, so bekomme ich im Log-File folgende Fehler:
Permission denied
Use -s to search $PATH for it

Beide Dateien haben die gleichen Rechte. Alle Verknüpfungen in dem Verzeichnis funktioniren nicht, alle .PL-Dateien wurderbar.
Würde mich freuen, wenn mir jemand helfen kann. Verwende Apache 2.0.52 auf Fedora.

Gruss

Thomas
ThomasD
 
Posts: 7
Joined: 22. December 2004 14:45

Postby deepsurfer » 22. December 2004 16:48

schau mal ob bei der "datev.pl" in der aller ersten zeile der perl Interprerter eingetragen ist.
#!/usr/bin/perl

Es kann sein das die datev.pl eine steuerfunktion hat und dadurch extra nicht zum direktaufruf programiert wurde.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ThomasD » 22. December 2004 18:08

Hallo,

bei datev.pl handelt es sich um eine reine Verknüpfung zu am.pl. Enthält also keine Daten. Und am.pl funktioniert. In am.pl wird der jeweilige Aufrufname gepfüft und je nachdem, ob es direkt mit am.pl oder über die Verknüpfung von datev.pl augerufen wird, unterschiedlich reagiert. Habs nicht geprogt, will es nur zum laufen bringen.

Vielleicht gibt es noch eine Idee, an was es liegen kann.

Gruss

Thomas
ThomasD
 
Posts: 7
Joined: 22. December 2004 14:45

Postby deepsurfer » 23. December 2004 08:53

musstest du diese verlinkung anlegen oder war diese nach install des programms vorhanden ??


Ich würde zu testzwecken den Link löschen und die am.pl mit
Code: Select all
cp am.pl datev.pl

kopieren und schaun ob das script nun einwandfei läuft.

PS:
welches buchhaltungsprogramm ist das ??

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ThomasD » 23. December 2004 10:23

Hallo,

wenn ich die Datei in den neuen Namen copiere funktioniert die ganze Sache. Sind nur endlos viele Verknüpfungen. Das Programm heist LX-Office.

In httpd.conf hab ich auch bei Options FollowSymlinks angegeben.

Hab mir auch ein Testzenario aufgebaut. Einfach ein .PL-Datei erzeugt und diese mit rechten versehen. Diese getestet und Sie tut.

Danach hab ich eine Verknüpfung auf die Datei erzeugt, die Rechte noch einmal geprüft und dann versucht, den Link aufzurufen. Auch für dieses Verzeichnis hab ich Option ExecCGI Includes FollowSymlinks angegeben. Wenn ich dann den Link aufrufen möchte, funktioiert dier nicht.

Der Link an sich ist erlaubt, denn sonst würde eine andere Fehlermeldung ausgegeben werden. Es kommt immer diese dubiose 'Permission denied' die ich absolut nicht verstehe.

Muss doch irgend wie gehen?

Gruss

Thomas
ThomasD
 
Posts: 7
Joined: 22. December 2004 14:45

Postby deepsurfer » 23. December 2004 12:29

Wie hast du das LX installiert ...
Zuerst entpackt und dann via FTP auf den server oder direkt das tar.gz in das /www und dann entpackt mit tar -x .......... ????


Egal.... bist du nach Anleitung gegenagen ???
denn da steht alles drinn was zutun ist, denn das ganze LX hat nach dem entpacken die falsche Gruppenrichtlinie.

statt
Code: Select all
chown apache: -R lx-erp/


müsstest du schauen wie die Richtlinien bei dir lauten.
da sein sein kann das Feudora etwas eigensinnig arbeitet.

Code: Select all
chown ????.???? -R lx-erp/


chirio
Deep
Last edited by deepsurfer on 23. December 2004 14:00, edited 1 time in total.
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby deepsurfer » 23. December 2004 12:35

Bei mir läuft es soweit, muss nur noch nach Anleitung die Datenabnk aktivieren....

Da LX den Postgresql benutzt uind nicht Mysql !!
---- Verwechsle das nicht !! ---
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ThomasD » 23. December 2004 15:22

Hallo,

bin genau nach Anleitung vorgegangen. Das erste Mal gibt es das Problem, wenn ich admin.pl aufrufen möchte. Dies ist eine Datei, die auf login.pl zeigt. Und hier kommt dann der Fehler.

Das ganze kann nicht an dem LX-Office liegen, da ich in einem anderen verzeichnis eine PL-Datei erzeugt und verknüpft habe. Und da hat die Verknüpfung nicht funktioniert aber die eigendliche PL-Datei schon. Muss ein generelles Problem auf meinem Apache mit den Verknüpfungen sein.

Was meinst du mit
müsstest du schauen wie die Richtlinien bei dir lauten.
da sein sein kann das Feudora etwas eigensinnig arbeitet.

Da ich Lese, Schreib und Ausführ-Rechte für alle eingerichtet habe, dürfte es daran nicht liegen? Habe zusätzlich den Owner auf apache gestellt was meiner Meinung nach auch richtig sein sollte bei Fedora.

Bin gerade dabei, Fedora auf einer anderen Kiste komplet neu aufzusetzen, da mir die ganze Sache dubios vorkommt.

Gruss

Thomas
ThomasD
 
Posts: 7
Joined: 22. December 2004 14:45

Postby deepsurfer » 23. December 2004 16:13

Habe wohl deinen Fehler gefunden .....


du hattest geschrieben das dein lx im Verzeichniss
/var/www/cgi-bin/lxerp/ liegt.


was falsch ist.....!!!!!!!

LX im www Verzeichniss entpacken lassen, dann den langen
lxoffice-2004-12-19 namen mittels mv ..... auf lx-erp umsetzen lassen.

dann sieht es wie folgt aus
/var/www/lx-erp/ das CGI verzeichniss ist nicht notwendig, denn
durch die Änderungen in der HTTPD Conf wird dem /var/www/lx-erp/ CGI Ausführungsrechte zugewiesen.

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ThomasD » 24. December 2004 10:53

Hallo,

es funktioniert !!!

Herzlichen Dank noch einmal für Deine Mühe.

Gruß

Thomas
ThomasD
 
Posts: 7
Joined: 22. December 2004 14:45


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests