Apache2, 1 IP, SSL und mehrere virt. namebased Hosts

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2, 1 IP, SSL und mehrere virt. namebased Hosts

Postby der-joerch » 01. December 2004 02:18

Hallo,

muss leider von Apache1.3 auf Apache2 umsteigen und schon habe ich ein grosses Problem:

Mit einer IP einen SSL Host (443) und vier virt. namebased Hosts (80) darstellen.

Unter Apache1.3 war dies kein Problem, mit Apache2 kann ich parallel zum SSL-Host
nur einen zusätzlichen Standard-Host definieren.
Die 'NameVirtualHost' Schluesseldirective harmoniert nicht mit SSL, ist aber
erforderlich um mehrere virt. namebased Hosts zu bedienen.

Wie Eingangs erwaehnt, unter 1.3 funktionierte es einwandfrei, mit 2.0 bekomme ich es nicht hin.

Gibt es schon eine Loesung für den Apachen2 ?

Fragen, hoffend, dankend

lb gr Joerch
der-joerch
 
Posts: 3
Joined: 01. December 2004 00:49

Postby Wiedmann » 01. December 2004 03:39

unter 1.3 funktionierte es einwandfrei, mit 2.0 bekomme ich es nicht hin.
Gibt es schon eine Loesung für den Apachen2 ?


Die Konfiguration der Vhosts hat sich in Apache2 nicht, gegüber der in Apache1.3, geändert.

Wenn deine VHost - Konfiguration korrekt war (und nicht nur zufällig lief ;-) ), wird sie auch weiterhin tun.

Mit einer IP einen SSL Host (443) und vier virt. namebased Hosts (80) darstellen.

Das ist OK.

Die 'NameVirtualHost' Schluesseldirective harmoniert nicht mit SSL, ist aber erforderlich um mehrere virt. namebased Hosts zu bedienen.

Was hat der "NameVirtualHost" mit SSL zu tun? Sind ja verschiedene Ports die da benutzt worden.

BTW:
SSL enabled namesbasierende VHosts funktionieren nicht wirklich. SSL-VHosts können nur IP-basierend sein. (Was ja nach deiner Beschreibung bei dir gegeben ist)

Poste doch einfach mal deine "vhosts.conf"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 01. December 2004 08:56

sorry, wenn ich dazwischen funke...
aber auf welcher OS arbeitet dein Indianer??

chirio
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Rough » 01. December 2004 12:11

Hallo,

bei uns funktioniert das mit Apache/2.0.40 Server, standard Red Hat 9 Distribution, mit SSL VHosts. Kann natürlich sein, dass das nur geht, da es Subdomians sind.

In der Conf haben wir folgende Einträge:

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80
NameVirtualHost *:443


#
# Standard Seite
#
<VirtualHost *:80>
ServerName web.domain.de
.
.
.
</VirtualHost>

<VirtualHost *:443>
ServerName web.domain.de
.
.
.
</VirtualHost>


#
# VHost 1
#
<VirtualHost *:80>
ServerName v1.web.domain.de
.
.
.
</VirtualHost>

<VirtualHost *:443>
ServerName v1.web.domain.de
.
.
.
</VirtualHost>


#
# VHost 2
#
<VirtualHost *:80>
ServerName v2.web.domain.de
.
.
.
</VirtualHost>

<VirtualHost *:443>
ServerName v2.web.domain.de
.
.
.
</VirtualHost>

Ob das auch anders funktioniert, kann ich nicht sagen.

Viele Grüße
Rough
Rough
 
Posts: 1
Joined: 01. December 2004 11:52

Apache2, 1 IP, SSL und mehrere virt. namebased Hosts

Postby der-joerch » 01. December 2004 12:23

Hallo und Danke für dei flotte Reaktion.
Also, arbeite mit einem ded.Server (Strato) unter SuSE 9.1.
Habe nochmals alle einzelnen Konfig-Files (listen.conf, vhost.conf, vhost-ssl.conf) geprüft
und einen Mismatch der Portzuweisungen entdeckt (...:* bzw. ...:80 ...:443), so, nun läuft aber alles! :D
der-joerch
 
Posts: 3
Joined: 01. December 2004 00:49


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests