.htaccess Problem...

Alles, was den Apache betrifft, kann hier besprochen werden.

.htaccess Problem...

Postby VII » 22. October 2004 19:10

Hi

will meine Verzeichnisse per .htaccess schützen...erstelle die Datei...soweit keine Problem...wenn ich das Verzeichnis aufrufen will kommt auch die Aufforderung nach der Eingabe...aber wenn ich nun das vorher festgelegte Passwort und Benutzername eingebe...kommt die Aufforderung immer wieder...bis ich auf "Cancel" drücke...jemand ne Idee woran das liegt?

[VII]
VII
 
Posts: 19
Joined: 30. November 2003 11:12

Postby Wiedmann » 22. October 2004 19:12

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby VII » 22. October 2004 21:59

Hi

es funktioniert nur, wenn ich in der htpasswd unverschlüsselte Passwörter drinne habe...wenn ich md5 verschlüsselung einbaue...funktioniert es nicht mehr...wieso=

[VII]
VII
 
Posts: 19
Joined: 30. November 2003 11:12

Postby Wiedmann » 22. October 2004 22:24

wenn ich md5 verschlüsselung einbaue.

Was meinst du damit?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby VII » 22. October 2004 22:59

wenn in der htpasswd Datei anstatt:

administrator:geheim


das steht:

administrator:$1$FA0.ql2.$eRKYi/YxhBoI44/rBwUOO/


[VII]
VII
 
Posts: 19
Joined: 30. November 2003 11:12

Postby Wiedmann » 22. October 2004 23:18

Es sagt ja auch keiner das du PHP o.ä. (CRYPT_MD5) für die Erzeugung der Passwörter nehmen sollst. Beim Apachen ist dazu das Programm "htpasswd.exe" dabei.

Da kommt dann z.B. sowas raus:
administrator:geheim
Code: Select all
administrator:$apr1$hs......$U93yoDrSGEFKggnju.G8o.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests