Auflisten im Browser

Alles, was den Apache betrifft, kann hier besprochen werden.

Auflisten im Browser

Postby Antivirus » 14. April 2003 19:18

Sali zämme

Wenn ich mit meinem Browser in ein Verzeichnis gehe wo es keine index.html oder (.php, .htm, .... usw.) hat listet mir Apache das ganze auf.

kann man das irgendwie im der httpd.conf unterbinden?

Danke im Voraus
User avatar
Antivirus
 
Posts: 124
Joined: 11. April 2003 19:33

Postby Oswald » 14. April 2003 20:51

Hallo Anti!

In der httpd.conf etwas unter der folgenden Zeile

<Directory ".../htdocs">

findest Du:

Options Indexes FollowSymLinks MultiViews Includes ExecCGI

Einfach vor das Indexes ein Minus-Zeichen setzen:

Options -Indexes FollowSymLinks MultiViews Includes ExecCGI

Das war's!

Liebe Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby operator » 13. November 2003 01:06

okay, das ist schonmal super!

jetzt noch eine frage, wo kann man den Text der dann kommt
verändern (also wo finde ich den).

Wäre doch nice dann ein rießen Logo zu machen, wie z.B.

Access forbidden... oder sowas...
operator
 

Postby René » 14. November 2003 16:15

ich vermute, dir geht es nicht um alle Ordner, aber in 2 oder 3 hast du etwas sensibles drinne ...

warum legst du nicht in diese ordner eine index.html rein - diese ist so gut wie leer, und gibt dein gewünschtes Bild aus ...
René
 
Posts: 7
Joined: 17. October 2003 11:27

Postby Heini_net » 14. November 2003 16:20

ne er meint die Fehlermeldung, die er modifizieren will.. mit seinem eigenen Logo usw..

ich selber hab es auch nicht hinbekommen.. da es Var dateien sind.. und ich kenn die jeweiligen syntaxe nicht.. handelt es sich um php dateien ??

Mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier

Postby nemesis » 15. November 2003 00:39

C:\xampp\apache\error\include
Da ist die Datei top.html drinnen, dort kannst du ein Bild angeben, die var Datein im error Ordner sind nur wegen der verschiedenen Sprachen vorhanden. Und die Scriptsprache ist SSI (Server Side Includes). Apache seine Standardsprache, php ist erst später aufgetaucht.
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby WebY » 10. July 2004 17:48

Kai Seidler wrote:Hallo Anti!

In der httpd.conf etwas unter der folgenden Zeile

<Directory ".../htdocs">

findest Du:

Options Indexes FollowSymLinks MultiViews Includes ExecCGI

Einfach vor das Indexes ein Minus-Zeichen setzen:

Options -Indexes FollowSymLinks MultiViews Includes ExecCGI

Das war's!

Liebe Grüße,
Oswald ;)




Kuhl:

Forbidden
You don't have permission to access / on this server.


--------------------------------------------------------------------------------

Apache/2.0.50 (Win32) mod_ssl/2.0.50 OpenSSL/0.9.7d PHP/4.3.7 Server at localhost Port 8080
WebY
 
Posts: 14
Joined: 08. July 2004 14:55


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests