Localhost hat den Verbindungsaufbau verweigert

Alles, was den Apache betrifft, kann hier besprochen werden.

Localhost hat den Verbindungsaufbau verweigert

Postby shine » 19. October 2004 13:20

ich habe den apache webserver auf suse 9.1 installiert und mit ./apachectl start gestartet. er läuft also.

anschliessend wollte ich mit http://localhost die Startseite öffnen und die folgende Fehlermeldung erschien:

"Localhost hat den Verbindungsaufbau verweigert"

woran kann das liegen???


danke für jede hilfe

gruss shine
shine
 
Posts: 5
Joined: 19. October 2004 13:11

Postby PF4 » 19. October 2004 15:19

Das Apache garnicht läuft z.b!

Nur weil du das Startcommand tippst heißt das garnix.
Kuk mal in die Logs usw.
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

apache gestartet mit ./apachectl

Postby shine » 20. October 2004 06:16

Ich habe den Apache Webserver gestartet mit

./apachectl start

und folgende Meldung wurde angezeigt:

./apachectl start: httpd started

dann sollte der Apache doch gestartet sein oder???

bin recht neu auf diesem Gebiet

danke für die Hilfe....

gruss
shine
 
Posts: 5
Joined: 19. October 2004 13:11

log files angeschaut

Postby shine » 20. October 2004 06:37

ok ich habe nun das logfile noch angeschaut und siehe da. er wird anscheinend wirklich nicht gestartet.

das sind die zeilen des log-files, nur sagt mir das nicht sehr viel aus:

[Mon Oct 18 11:57:44 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Mon Oct 18 11:57:44 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Mon Oct 18 11:57:47 2004] [notice] caught SIGTERM, shutting down
[Mon Oct 18 11:57:52 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Mon Oct 18 11:57:52 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Mon Oct 18 16:08:02 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 09:06:52 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Tue Oct 19 09:06:52 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Oct 19 10:36:30 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 10:36:35 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Tue Oct 19 10:36:35 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Oct 19 13:42:00 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 13:42:04 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Tue Oct 19 13:42:04 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Oct 19 14:44:39 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 14:44:43 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Tue Oct 19 14:44:43 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Oct 19 15:25:02 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 15:25:03 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Tue Oct 19 15:25:03 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Oct 19 15:28:17 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 15:28:18 2004] [notice] Apache/1.3.31 (Unix) configured -- resuming normal operations
[Tue Oct 19 15:28:18 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Tue Oct 19 15:33:23 2004] [notice] caught SIGTERM, shutting down
[Tue Oct 19 15:33:25 2004] [crit] (13)Permission denied: make_sock: could not bind to port 80
[Tue Oct 19 15:43:50 2004] [crit] (13)Permission denied: make_sock: could not bind to port 80
[Wed Oct 20 07:12:45 2004] [crit] (13)Permission denied: make_sock: could not bind to port 80

kann mir hier jemand helfen? thanks... :cry:
shine
 
Posts: 5
Joined: 19. October 2004 13:11

Postby Kristian Marcroft » 20. October 2004 08:42

Hi,

[Wed Oct 20 07:12:45 2004] [crit] (13)Permission denied: make_sock: could not bind to port 80

Irgendwas blockiert deinen Port 80 bzw. du hast keine Zugriff darauf.
Such mal nach make_sock hier im Forum oder in der FAQ.

Findest nur ca. 199 Beiträge...
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Port zuweisung

Postby shine » 20. October 2004 09:33

danke für die infos!

habe noch keine wirkliche lösung gefunden. weisst du evtl. gerade mit welchem befehl man im linux die portzuweisung abfrägt?
shine
 
Posts: 5
Joined: 19. October 2004 13:11

Postby Kristian Marcroft » 20. October 2004 09:46

Hi,

fuser -v 80/tcp

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby shine » 20. October 2004 10:07

nun bekomme ich die antwort

here: 80

wird mit diesem befehl nicht nur der benutzer ausgegeben der den port 80 verwendet, das ist klar das ich das bin.

aber ich möchte ja das programm, welches den port80 verwendet herausfinden!!!
shine
 
Posts: 5
Joined: 19. October 2004 13:11

Postby Kristian Marcroft » 20. October 2004 10:49

Hi,

bei mir sieht das dann so aus:
Code: Select all
# fuser -v 80/tcp

                     USER        PID ACCESS COMMAND
80/tcp               root       9088 f....  httpd
                     root       9104 f....  httpd
                     root       9111 f....  httpd
                     root       9112 f....  httpd
                     root       9113 f....  httpd
                     root       9114 f....  httpd
                     root       9115 f....  httpd
                     root       9116 f....  httpd
                     root       9146 f....  httpd
                     root       9148 f....  httpd
                     root       9149 f....  httpd
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests