Apache force Downlaod Modus(browser zeigt nichts an)

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache force Downlaod Modus(browser zeigt nichts an)

Postby pizzadox » 27. October 2019 22:55

Hallo werte Community,

mir ist ein Problem untergekommen, dass Apache bzw. der Webserver in einer Art "force-downlaod" Modus ist. Immer, wenn ich mich drauf verbinde, wird eine Datei heruntergeladen. Dies ist browserunabhängig getestet mit Chrome und Internet Explorer. pizzanetwork.ddns.net ist der Webserver falls sich jemand dem Problem annehmen möchte. Wenn das Problem schon irgendwo gelöst wurde, würde ich um den entsprechenden Link bitten. Wenn jmd. irgendwelche ini Files braucht bitte bescheid sagen.

Vielen Dank MFG eurer pizzadox
pizzadox
 
Posts: 2
Joined: 27. October 2019 22:46
XAMPP version: Leider nur apache
Operating System: archLinux

Re: Apache force Downlaod Modus(browser zeigt nichts an)

Postby Altrea » 28. October 2019 08:01

Hallo,

Hier bei uns bist du leider falsch. Wir leisten in diesem Forum ausschließlich Support für Apache Konfigurationen, die aus XAMPP Installationen heraus stammen.
Aber mal ein Schuss ins Blaue; Es sieht so aus, als ob dein Apache PHP nicht parst. Da würde ich ansetzen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9896
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache force Downlaod Modus(browser zeigt nichts an)

Postby Nobbie » 28. October 2019 12:27

Der Apache Server übermittelt den falschen MIME-Type, aus welchem Grund auch immer. Entweder eine fehlerhafte .htaccess, oder eine fehlerhafte httpd.conf oder sowieso falsche MIME-Types oder oder oder - irgendetwas hast Du zerschossen. Aber mit dem MIME-Type, das müßte Dir etwas sagen, wenn es Dir gar nichts sagt, dann würde ich den kompletten Apache nochmal runterwerfen und alles neu installieren.

Oder gleich Xampp installieren, dann bist Du auch im richtigen Forum...

P.S.: Hier ist der komplette HTTP Header, der von Deinem Server kommt:

HTTP/1.1 200 OK
Date: Mon, 28 Oct 2019 11:34:53 GMT
Server: Apache/2.4.37 (Unix)
Last-Modified: Sun, 27 Oct 2019 21:42:48 GMT
ETag: "12-595eb43aabb1c"
Accept-Ranges: bytes
Content-Length: 18
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: application/x-httpd-php


Der Content-Tyoe application/x-httpd-php ist falsch, das veranlasst den Browser zum Download. Die Datei heißt index.html (wenn man nur die Domain eingibt), da müßte text/html o.ä. als Content-Type stehen. Auf Deinem Server ist application/x-httpd-php der richtige Type, damit Apache veranlasst wird, den PHP Code zu parsen. Aber das Resultat ist HTML und das wird an den Browser gesendet. Das geht aber vollständig in die Hose. Ich vermute mal, dass Du mit CGI oder so herumexperimentierst und falsche Optionen gesetzt hast. Oder dass Du erreichen willst, dass HTML auch als PHP geparsed werden. Auf alle Fälle ist irgendwo der falsche Content-Type gesetzt.
Nobbie
 
Posts: 11249
Joined: 09. March 2008 13:04

Re: Apache force Downlaod Modus(browser zeigt nichts an)

Postby pizzadox » 28. October 2019 16:08

Vielen dank ich werde da ansetzen wo ihr gesagt habt. Viele Grüße und großen dank pizzadox
pizzadox
 
Posts: 2
Joined: 27. October 2019 22:46
XAMPP version: Leider nur apache
Operating System: archLinux


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests