Apache Gateway Return Code

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache Gateway Return Code

Postby eljot31 » 21. June 2019 08:00

Hallo,

ich bin neu hier und hätte auch gleich eine Frage, welche mir bestimmt einer der Mitglieder beantworten kann :)

Ich betreibe einen Apache 2.4 unter RedHat als https-Gateway mit Loadbalancer zu mehreren Tomcat 8.5 Instanzen.
Nun kommt es manchmal vor, dass es im Tomcat Servlet einen parse error gibt, welcher im Tomcat-Log mit ReturnCode 500 steht. Im Apache-Log erhalte ich aber einen ReturnCode 200. Ich bin etwas ratlos, weshalb Apache den ReturnCode 500 nicht erhält. Bei anderen Rückmeldungen 403,404,409 funktioniert es.

Tomcat localhost_access_log.2019-06-20.txt
139.21.70.170 - - [20/Jun/2019:16:55:52 +0200] "POST /arlink/archiv?create... HTTP/1.0" 500 -

Apache access_al_utf8_log.2019.06.20
[20/Jun/2019:16:55:52 +0200] 146.254.190.235:443 139.21.70.170 TLSv1.2 ECDHE-RSA-AES128-GCM-SHA256 "POST /arlink/archiv?create... HTTP/1.0" 200 - "-" "SAPHTTP" 1876

Apache Config:
Code: Select all
<IfModule proxy_module>
    Listen 0.0.0.0:8443 https
    Listen 0.0.0.0:18443 https
    Listen 0.0.0.0:28443 https
    Listen 0.0.0.0:38443 https
    Listen 0.0.0.0:48443 https
    Listen 0.0.0.0:58443 https

        <Proxy "balancer://cluster_utf8">
                BalancerMember "ajp://localhost:8019" route=node1
                BalancerMember "ajp://localhost:8029" route=node2
                ProxySet lbmethod=bybusyness timeout=15
        </Proxy>

        <Proxy "balancer://cluster_iso8859">
                BalancerMember "ajp://localhost:8039" route=node3
                BalancerMember "ajp://localhost:8049" route=node4
                ProxySet lbmethod=bybusyness timeout=15
        </Proxy>


        # mod_proxy
        <VirtualHost *:8443 *:18443 *:48443 *:58443>
                DocumentRoot /var/opt/apache/htdocs
                ErrorLog "| /usr/sbin/rotatelogs /var/opt/apache/logs/error_al_iso_log.%Y.%m.%d 86400"
                LogLevel notice
                CustomLog "| /usr/sbin/rotatelogs /var/opt/apache/logs/access_al_iso_log.%Y.%m.%d 86400" "%t %A:%p %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %D"

                <Directory /var/opt/apache/pegasus.erlm.siemens.de/htdocs>     
                     Require all granted
                </Directory>

                ProxyPass /arlink/archiv balancer://cluster_iso8859/arlink/archiv
                ProxyPassReverse /arlink/archiv balancer://cluster_iso8859/arlink/archiv
        </VirtualHost>

        <VirtualHost *:28443 *:38443>
                DocumentRoot /var/opt/apache/htdocs
                ErrorLog "| /usr/sbin/rotatelogs /var/opt/apache/pegasus.erlm.siemens.de/logs/error_al_utf8_log.%Y.%m.%d 86400"
                LogLevel notice
                CustomLog "| /usr/sbin/rotatelogs /var/opt/apache/pegasus.erlm.siemens.de/logs/access_al_utf8_log.%Y.%m.%d 86400" "%t %A:%p %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %D"

                ProxyPass /arlink/archiv balancer://cluster_utf8/arlink/archiv
                ProxyPassReverse /arlink/archiv balancer://cluster_utf8/arlink/archiv
        </VirtualHost>
</IfModule>


Vielen Dank für Eure Unterstützung
Grüße
Jochen
eljot31
 
Posts: 1
Joined: 21. June 2019 07:45
XAMPP version: 7
Operating System: Windows 7, Windows 10, RHEL7.5

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests