Probleme bei AuthLDAP gegen AD Komma in DN

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme bei AuthLDAP gegen AD Komma in DN

Postby WebMonkey » 23. April 2018 10:06

Hallo,

ich verwende den Apachen 2.4 mit mod_authnz_ldap um damit gegen ein AD zu authentifizieren.
Die Authentifikation mit Require valid-user funktioniert soweit ganz gut.
Ich will aber den Apachen mit Require ldap-group verwenden.

Im CN des DNs steht der Vorname und der Nachname mit Komma getrennt.

Der GruppenDN sieht ungefähr so aus:
CN=ADTest,OU=Apache,OU=sonstiges,OU=Gruppen,OU=IT,OU=Abteilungen,DC=ACTIVEDIR,DC=TEST,DC=DE

Der UserDN sieht ungefähr so aus:
CN=White, Walter,OU=Muenchen,OU=Benutzer,OU=IT,OU=Abteilungen,DC=ACTIVEDIR,DC=TEST,DC=DE

Die Config sieht etwa so aus:
-------------------------------------------------------------------------------------
<AuthnProviderAlias ldap AD01>
AuthLDAPBindDN ldapbind@myserver.de
AuthLDAPBindPassword Passwort
AuthLDAPURL "ldaps://ad.myserver.de:3269/OU=Benutzer,OU=IT,OU=Abteilungen,DC=ACTIVEDIR,DC=TEST,DC=DE?sAMAccountName?sub"
AuthLDAPGroupAttribute member
AuthLDAPGroupAttributeIsDN on
AuthLDAPRemoteUserIsDN on
</AuthnProviderAlias>

...

<Location /content/>
AuthType basic
AuthName "Secret"
AuthBasicProvider AD01

AuthLDAPCompareAsUser on
AuthLDAPRemoteUserIsDN on

<RequireAll>
Require ldap-group "CN=ADTest,OU=Apache,OU=sonstiges,OU=Gruppen,OU=IT,OU=Abteilungen,DC=ACTIVEDIR,DC=TEST,DC=DE"
</RequireAll>
</Location>

...

-------------------------------------------------------------------------------------

Ich habe keinen Zugriff auf die Logfiles des AD und kann die sichere Verbindung auch nicht sniffen.
Im Logfile des Apachen steht nur der Status 401.
Im Errorlog steht auch nichts zielführendes.

[Mon Apr 23 10:59:48.537168 2018] [authz_core:error] [pid 1970] [client 192.168.132.17:64647] AH01631: user CN=White\\, Walter,OU=Muenchen,OU=Benutzer,OU=IT,OU=Abteilungen,DC=ACTIVEDIR,DC=TEST,DC=DE: authorization failure for "/content/":

Der einzige Hinweis ist hier, dass der Apache das Komma doppelt maskiert.

Hat schonmal jemand dieses Problem gehabt und auch gelöst bekommen?
WebMonkey
 
Posts: 1
Joined: 23. April 2018 09:34
XAMPP version: 2.4
Operating System: Linux

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests