connect to ::1 port 80 failed: Verbindungsaufbau abgelehnt

Alles, was den Apache betrifft, kann hier besprochen werden.

connect to ::1 port 80 failed: Verbindungsaufbau abgelehnt

Postby JMRBerlin » 14. April 2018 12:33

Hallo NG,

zuerst mein Level, Beginner.

Ich richte mir gerade Schritt für Schritt und möglichst manuell (um zu Lernen), meinen Raspberry mit Raspbian und Apache ein. In Folge kommen PHP, SQL, Nextcloud, etc.

Die Installation des Apache mache ich nach folgendem Tutorial und habe Schritte 1 und 2 erledigt, Apache ist also installiert.

https://www.netnea.com/cms/apache_tutorial_1_apache_compilieren/
https://www.netnea.com/cms/apache_tutorial_2_apache_minimal_konfigurieren/

Der Aufruf http://192.168.178.220/index.html gibt mir "It works" aus.

Der erweiterte Check mit

Code: Select all
JMR@raspi:/apache/bin $ curl --verbose http://localhost/index.html


ergibt aber

Code: Select all
*   Trying ::1...
* TCP_NODELAY set
* connect to ::1 port 80 failed: Verbindungsaufbau abgelehnt
*   Trying 127.0.0.1...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 80 (#0)
> GET /index.html HTTP/1.1
> Host: localhost
> User-Agent: curl/7.52.1
> Accept: */*


Der Inhalt der Config-Datei wurde nach dem Tutorial bearbeitet und lautet wie folgt:

Code: Select all
ServerName              localhost
ServerAdmin             root@localhost
ServerRoot              /apache
User                    www-data
Group                   www-data
PidFile                 logs/httpd.pid

ServerTokens            Prod
UseCanonicalName        On
TraceEnable             Off

Timeout                 10
MaxRequestWorkers       100

Listen                  127.0.0.1:80

LoadModule              mpm_event_module        modules/mod_mpm_event.so
LoadModule              unixd_module            modules/mod_unixd.so

LoadModule              log_config_module       modules/mod_log_config.so

LoadModule              authn_core_module       modules/mod_authn_core.so
LoadModule              authz_core_module       modules/mod_authz_core.so

ErrorLogFormat          "[%{cu}t] [%-m:%-l] %-a %-L %M"
LogFormat               "%h %l %u [%{%Y-%m-%d %H:%M:%S}t.%{usec_frac}t] \"%r\" %>s %b \
\"%{Referer}i\" \"%{User-Agent}i\"" combined

LogLevel                debug
ErrorLog                logs/error.log
CustomLog               logs/access.log combined

DocumentRoot            /apache/htdocs

<Directory />
     
    Require all denied

    Options SymLinksIfOwnerMatch

</Directory>

<VirtualHost 127.0.0.1:80>
     
      <Directory /apache/htdocs>

        Require all granted

        Options None

      </Directory>

</VirtualHost>


Ich möchte nun sehr frühzeitig die Fehler lösen, auch wenn der Apache selbst eine richtige Ausgabe gebracht hat, um nicht später, wenn die Eingrenzung noch aufwendiger wird, Ärger zu bekommen.

Für mich stellt sich die Frage, wie es bei dieser Minimalkonfiguration zur Fehlermeldung

Code: Select all
Trying ::1...
* TCP_NODELAY set
* connect to ::1 port 80 failed: Verbindungsaufbau abgelehnt


kommen kann und wie Apache auf die Idee kommt, bei dieser Konfiguration einen Verbindungsversuch zu ::1... zu machen

Kann mir das jemand erklären und sagen, was ich ändern muss, damit die Fehlermeldung ausbleibt?

Danke und viele Grüße

Jörg
JMRBerlin
 
Posts: 7
Joined: 14. April 2018 12:24
XAMPP version: 5.6
Operating System: Debian 9 (Raspbian)

Re: connect to ::1 port 80 failed: Verbindungsaufbau abgeleh

Postby Nobbie » 14. April 2018 22:43

JMRBerlin wrote:Für mich stellt sich die Frage, wie es bei dieser Minimalkonfiguration zur Fehlermeldung

Code: Select all
Trying ::1...
* TCP_NODELAY set
* connect to ::1 port 80 failed: Verbindungsaufbau abgelehnt


kommen kann und wie Apache auf die Idee kommt, bei dieser Konfiguration einen Verbindungsversuch zu ::1... zu machen


Wie kommst Du auf die Idee, dass Apache den Verbindungsversuch auf ::1 macht?? Lösche Apache und Du wirst sehen, die Meldung bleibt die gleiche. Es ist das Programm "curl", das Du aufgerufen hast (und welches NICHTS mit Apache zu tun hat), welches den Verbindungsversuch auf ::1 macht.

::1 ist der Syntax von IPv6 für die bekannte Adresse 127.0.0.1 unter IPv4. Wahrscheinlich ist entweder in /etc/hosts der Eintrag localhost mit ::1 verknüpft, oder der DNS Dienst von Raspian ist auf andere Weise so konfiguriert, dass localhost auf ::1 aufgelöst wird.

Last not least bist Du hier leider total falsch in diesem Forum, diese Frage hat weder mit Xampp, noch mit Apache, sowieso nichts mit Xampps Apache zu tun und schon überhaupt gar nichts mit der Installation von Xampps Apache (das ist das Thema dieses Forums). Deine Frage ist eine reine Raspian Frage aus dem Bereich TCPIP und DNS, nur um Dir ein paar Stichwörter für die Suche nach einem geeigneten Forum zu geben.
Nobbie
 
Posts: 10457
Joined: 09. March 2008 13:04

Re: connect to ::1 port 80 failed: Verbindungsaufbau abgeleh

Postby JMRBerlin » 15. April 2018 09:21

Ok, vielen Dank für die ausführliche Erläuterung. VG Jörg
JMRBerlin
 
Posts: 7
Joined: 14. April 2018 12:24
XAMPP version: 5.6
Operating System: Debian 9 (Raspbian)


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests