Passwortzugriff für server-info einrichten

Alles, was den Apache betrifft, kann hier besprochen werden.

Passwortzugriff für server-info einrichten

Postby buschu » 28. March 2018 13:04

Ich soll auf unseren Apache-Servern (2.4 unter SLES 12 SP3) server-info mit Passwortschutz einrichten. Server-info läuft, aber ich schaffe es nicht, dass erst mal die Passwortabfrage kommt. Was habe ich bisher versucht?

Die Datei mod_info.conf sieht so aus:

<IfModule mod_info.c>
<Location /server-info>
SetHandler server-info
Require all denied
<IfModule !mod_access_compat.c>
Require local
</IfModule>
<IfModule mod_access_compat.c>
Error "Module mod_access_compat loaded"
</IfModule>
AuthType Basic
AuthName "Vertraulicher Bereich"
AuthBasicProvider file
AuthUserFile /usr/share/apache2/.htpasswd
Require user <Benutzername>
</Location>
<Directory /usr/share/apache2>
AllowOverride All
</Directory>
</IfModule>

Und die Datei /usr/share/apache2/.htpasswd habe ich natürlich mit htpasswd erstellt. Was mir jetzt zu meinem Glück noch fehlt, ist die Passwortabfrage, aber da kommt nichts.
Ich habe folgende Variationen schon durchprobiert: Statt explizit den einzigen User anzugeben, habe ich es mit "valid_user" probiert. Dann habe ich mal die Auth-Angaben in einen neuen Directory-Abschnitt geschrieben. Hat alles nichts geändert. Natürlich habe ich jedesmal im Firefox Strg-F5 benutzt, um die Seite komplett neu zu laden, habe auch extra mal den Firefox neu gestartet. Half bisher alles nichts.

Vielen Dank für jede konstruktive Antwort!

Grüße
Burkhard
buschu
 
Posts: 2
Joined: 28. March 2018 12:52
XAMPP version: 2.4
Operating System: Linux

Re: Passwortzugriff für server-info einrichten

Postby Nobbie » 29. March 2018 04:37

1) Eigentlich bist Du hier falsch, das Forum ist das Supportforum für die Xampp Installation und dessen Komponenten. Du hast weder Xampp installiert, noch ein Problem bei der Xampp Installation.

2) Unabhängig davon empfehle ich Dir, wirklich nur die Passwortabfrage zu implementieren und nicht (wie momentan) elfundneunzig andere Dinge, deren Sinn und Zweck sich ohnehin keinem erschliesst. Konkret: schmeiss die ganzen ifmodules raus, schmeiss die unverständliche Sethandler Anweisung raus, schmeiss die nicht nachvollziehbare Directory Klausel, schmeisse alles raus bis auf die notwendigen Auth... Anweisungen und die einzige Require user Anweisung. Dann erst tust Du wirklich das, was Du oben vorgibst, nämlich erst einmal "nur" die Passwortabfrage implementieren.

3) Last not least schaust Du in den Error Log, ob es ggf. irgendein Problem gibt. Vorher Apache neu starten. Und stelle sicher, dass die mod_info.conf auch wirklich berücksichtigt wird.
Nobbie
 
Posts: 10445
Joined: 09. March 2008 13:04

Re: Passwortzugriff für server-info einrichten

Postby buschu » 29. March 2018 14:41

Hallo Nobbie,

mir ist zu spät aufgefallen, dass ich hier nicht richtig bin. Ich werde es im guten, alten Usenet probieren.

Aber danke für deine Hilfe!

Grüße
Burkhard
buschu
 
Posts: 2
Joined: 28. March 2018 12:52
XAMPP version: 2.4
Operating System: Linux


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests