How Can I Fix HeartBleed on Apache 2.2

Alles, was den Apache betrifft, kann hier besprochen werden.

How Can I Fix HeartBleed on Apache 2.2

Postby sandroroussenq » 27. March 2018 21:33

Hello,
I´m trying to fix HeartBleed vulnerability on Apache 2.2.
Does Anyone can help me?

These are the specs of my Server:

- O.S: Windows Server 2003
- Apache HTTP Server 2.2.14
- OpenSSL 1.0.0a Light

Thanks!!!
Sandro Roussenq de Sá
sandroroussenq
 
Posts: 2
Joined: 27. March 2018 19:34
Operating System: Win Server 2003

Re: How Can I Fix HeartBleed on Apache 2.2

Postby Nobbie » 28. March 2018 05:52

Heartbleed is/was not an Apache vulnerabilty, but of OpenSSL instead. OpenSSL from version 1.0.1 thru 1.0.1f are affected, it was fixed in 2014 with 1.0.1g.

Obviously youre installation is so old, that it is not affected, you cannot fix what is not there. Of course you may install a newer OpenSSL if you like, but anyway your OpenSSL is not yet affected by Heartbleed.
Nobbie
 
Posts: 10281
Joined: 09. March 2008 13:04

Re: How Can I Fix HeartBleed on Apache 2.2

Postby sandroroussenq » 28. March 2018 12:46

Hi Nobbie,

Thank you so much for clarifying my issue.

Regards!
Sandro Roussenq de Sá
sandroroussenq
 
Posts: 2
Joined: 27. March 2018 19:34
Operating System: Win Server 2003


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests