Domains einrichten klappt nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Domains einrichten klappt nicht

Postby Friedel » 23. February 2018 12:38

Hallo,

ich versuche gerade zum ersten mal Domains ein zu richten. Bisher habe ich den lokalen Apache immer nur für eine Website zum Testen benutzt. Da waren keine Domains nötig. Aber jetzt brauche ich ihn für mehrere Websites, die lokal getestete werden sollen.

Ich habe mit Google recht viele Anleitungen gefunden und bin nach http://www.matthias-zeis.com/ressourcen/zfstde/zfbook.creating.a.local.domain.using.apache.virtual.hosts.html vorgegangen.

Mein OS ist Debian 8.

Zuerst habe ich die Datei /etc/apache2/sites-available/000-default.conf als Root geöffnet. Der Inhalt war:
Code: Select all
<VirtualHost *:80>
   # The ServerName directive sets the request scheme, hostname and port that
   # the server uses to identify itself. This is used when creating
   # redirection URLs. In the context of virtual hosts, the ServerName
   # specifies what hostname must appear in the request's Host: header to
   # match this virtual host. For the default virtual host (this file) this
   # value is not decisive as it is used as a last resort host regardless.
   # However, you must set it for any further virtual host explicitly.
   #ServerName www.example.com

   ServerAdmin webmaster@localhost
   DocumentRoot /var/www/html

   # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
   # error, crit, alert, emerg.
   # It is also possible to configure the loglevel for particular
   # modules, e.g.
   #LogLevel info ssl:warn

   ErrorLog ${APACHE_LOG_DIR}/error.log
   CustomLog ${APACHE_LOG_DIR}/access.log combined

   # For most configuration files from conf-available/, which are
   # enabled or disabled at a global level, it is possible to
   # include a line for only one particular virtual host. For example the
   # following line enables the CGI configuration for this host only
   # after it has been globally disabled with "a2disconf".
   #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet


Das habe ich um folgendes ergänzt:
Code: Select all
# Einrichtung des virtuellen Hosts "friedels-home.de-loc"
<VirtualHost *:80>
    ServerName friedels-home.de-loc
    DocumentRoot /media/sdb1/friedels-home.de

    <Directory /media/sdb1/friedels-home.de>
        Options Indexes FollowSymLinks Includes
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>


Außerdem habe ich die Datei /etc/apache2/sites-available/friedels-home.de-loc.conf erzeugt, die genau den Text enthält, mit dem ich die /etc/apache2/sites-available/000-default.conf erweitert habe.

Dann habe ich in der /etc/hosts nach der Zeile
Code: Select all
127.0.0.1   localhost
die Zeile
Code: Select all
127.0.0.1   friedels-home.de-loc

eingefügt.

Mit
Code: Select all
sudo a2ensite friedels-home.de-loc
habe ich dann die neue Domain aktiviert und mit
Code: Select all
sudo /etc/init.d/apache2 reload
die neue Konfiguration geladen.

Wenn ich jetzt im Browser die Adresse http://friedels-home.de-loc eingebe, kommt ein 500 Internal Server Error. Was habe ich falsch gemacht? (Und wie geht es richtig?)
Friedel
 
Posts: 3
Joined: 05. August 2007 01:33

Re: Domains einrichten klappt nicht

Postby Nobbie » 23. February 2018 21:34

Ein 500er Fehler ist ein schwerer Syntaxfehler (meistens) und da er erst auftritt, wenn Du diese Adresse im Browser eingibst, spricht vieles dafür, dass die Konfiguration nicht fehlerhaft ist (dann würde schon beim Start von Apache ein Fehler kommen), sondern dass entweder ein schwerer Programmierfehler in einem PHP Script vorliegt oder in einer lokalen .htaccess Datei irgendetwas nicht stimmt. Eigentlich sollte eine ausführlichere Meldung im error_log stehen, ggf. musst Du die Konfiguration noch anpassen, damit ein error_log geschrieben wird. Aber erst einmal würde ich da nachschauen, ob es da irgendetwas genaueres gibt.

Es kann auch ein Laufzeitfehler sein, beispielsweise ein rekursiver unendlicher Loop, eine Weiterleitung die immer wieder weiterleitet oder so. Leider wissen wir hier rein gar nichts über den Inhalt dieser Domain, tritt der Fehler denn auch auf, wenn da nichts drin steht (keine Datei, gar nichts)?

P.S.: Im localhost hast Du einen error_log eingerichtet ( ErrorLog ${APACHE_LOG_DIR}/error.log), es wäre sinnvoll, das auch für alle anderen VirtualHosts zu tun. SInnvollerweise mit einem anderen Dateinamen (error-friedel-home.log oder so). Da würde dann eine sehr hilfreiche Fehlermeldung zu erwarten sein.
Nobbie
 
Posts: 10618
Joined: 09. March 2008 13:04

Re: Domains einrichten klappt nicht

Postby Friedel » 24. February 2018 01:26

Danke für den Hinweis. Das hat auch was genützt. Aber leider bin ich noch nicht am Ziel.

Ich habe also dafür gesorgt, dass eine error-friedels-home-de.log erzeugt wird und habe dann nachgesehen, welche Fehlermeldung dort geloggt wird.
Code: Select all
[Sat Feb 24 01:13:10.655203 2018] [core:alert] [pid 1386] [client 127.0.0.1:52803]  /media/sdb1/friedels-home.de/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

OK. Das brauche ich vorläufig lokal nicht. Also habe ich die .htaccess umbenannt. Jetzt kommt ein Fehler 403 (Forbidden - You don't have permission to access / on this server.) Und in der error-friedels-home-de.log steht dann
Code: Select all
[Sat Feb 24 01:16:15.208828 2018] [authz_core:error] [pid 1387] [client 127.0.0.1:52810] AH01630: client denied by server configuration: /media/sdb1/friedels-home.de/
Friedel
 
Posts: 3
Joined: 05. August 2007 01:33

Re: Domains einrichten klappt nicht

Postby Friedel » 24. February 2018 04:40

OK. Ich hab's rausgefunden. In der apache.conf musste noch
Code: Select all
<Directory /media/sdb1/friedels-home.de/>
   Options Indexes FollowSymLinks
   AllowOverride None
   Require all granted
</Directory>

eingefügt werden.
Friedel
 
Posts: 3
Joined: 05. August 2007 01:33

Re: Domains einrichten klappt nicht

Postby Nobbie » 24. February 2018 11:18

by Friedel » 24. February 2018 04:40


hihi....
Nobbie
 
Posts: 10618
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests